How long is T.E. Support taking at the moment?


#1

Not ranting , just genuinely want an idea. I mailed them about my OPz Three weeks ago and still no reply ?


#2

Have you tried to call them by phone? It may speed things up (or not)…


#3

i sent them a few mails “recently” : december 8 i kindly asked them for an OP-1 repair (to wich they only responded january 30 once i said to them “i’ve finally done it myself”). in february i sent another request for another OP-1 repair, but never had an answer. then april 11, i asked them why is it impossible to backup recorded samples from the Ghostly PO-33 (that i’ve been stupid enough to buy), they still didn’t answer me… this finally opened my eyes and that’s the reason why i’ve just gave up with them and their products, there are surely some manners to get them to respond quickly (like the phone if you can speak english or suedish), personally i sold everything to solve the problem and feel better. :v:


#4

I got an answer a week ago after 2 monts of waiting.


#5

Took me about two weeks, I sent them a reminder and they replied after that. The ensuing mail conversation has been quite rapid.

I’m writing them in swedish by the way, not sure if that has something to do with it.

I’m pretty sure their support line is still swamped and will be so for a forseeable future. I work with something similar and I know what it’s like, so I’m trying to be as friendly as I can when I’m dealing with them.


#6

I just recently had an issue with the connector board. The right channel of the headphone jack was not working properly, and I could only hear sound when pressing on the plug a bit.

Hearing about all these support stories I really didn’t feel like sending my unit to TE and waiting for ages. I opened the connector board cover and after taking a look I noticed a loose solder joint on the headphone jack.

Although I was nervous af I just re soldered the loose joint on the jack connector back to the connector board. Works just like it should now :slight_smile:


#7

Well I sent a reply to the first support request , showing a video of my issue. 5 weeks later I got my reply.

To be fair they did get back to me, after they checked on the issue to see whether it was hw or sw issue, without me chasing.

Appears it’s a sw issue, although I’d appreciate if anybody can confirm this.

On project 1 I could only save in auto mode, manual mode wouldn’t save. This was only on project 1, other projects saved fine in both modes.