Midi out from the OP-1. How?

I found this super long thread, and unfortunately very hard to follow. :frowning: The Definitive Guide to Trying to Connect Your OP-1 Via USB-MIDI

I simply want to use the OP-1 to connect to my Korg NTS-1 (I already have a Type-A midi adapter). As of now, what is the easiest device that does this? I want a simple USB midi in to DIN midi out box.

crontabs on a Raspberry Pi

Was it ever established that this works? Miditech USB

Or this one?

Retrokits RK005 works.

1 Like

This looks cool as well as the RK006 big brother. Looks like it’s only shipped from Europe (no US distributers). OK will have to have to look into this. Thanks for the recommendation.

1 Like

Disaster area midi USB host works wonderfully

Is this the one? https://www.disasterareaamps.com/shop/micro-ghost

If at some point you wish to have several other boxes, considering something like a MIO4 could be a good idea…
Anyway, to synchronize OP-1, you need such kind of USB hub.
This said, OP-1 has the bad behavior that it resends the clock when in sync mode, and this can’t be deactivated (unless the las OS takes care of this, I should check).
So you need to be able to deactivate midi sync from your usb midi hub.
MIO4 can take care of this, but a RasPi solution might be as good and cheaper :slight_smile:

Your comment about OP-1’s midi sync is very curious. So you are saying this is causing a known issue? What exactly happens when the OP-1 does this?

Say my Octatrack is the master, Sync out only, and A4 + OP-1 are plugged in the same MIDI USB hub: as OP-1 is resending the clock, A4 gets a double click and it’s bpm is thus OT bpm x2. Pretty annoying.
I reported it to Teenage Engineering, but if anyone can confirm this with last OS (still haven’t checked yet) please report as well.

i have a similar problem when connecting the op1 to other machines (asr10 and mv80000, via a motu timepiece midi patchbay) the op1 sometimes runs at double the bpm of the other machines.
i assumed it was a midi feedback issue – as i also get notes double triggering when using the mv800 and asr10 without the op1.

the motu timepiece midi hub i use is very sophisticated with filtering and routing etc. and should be able to defeat midi feedback very easily. i had some settings that were working, but i changed something and the problem returned. i can’t remember how i fixed it. so now i just yank out a mid out cable temporarily.

btw - the older motu timepeices sell for little. they make great usb patchbays.

1 Like

Resending incoming MIDI sync over USB is a heresy, clearly a bug.
To avoid such unwanted OP-1 behavior, you have to disable OP-1 sync out, or simply make it the master.

How do you disable the sync out? I don’t recall seeing that setting.

Based on recommendations from people that have successfully got things to work, I ended up getting the MIDIPLUS USB host. Now things work fine. BUT things break when I start using the sequencers!! Once I activate the sequencers (endless, finger, etc…) after a short while, I hear a stuck note and then no midi! I have to reset the box. Not sure what is going on, but it feels like the OP-1 is somehow “flooding” the USB Host with midi data when the sequencers are active. Not sure if there is anything I can do on my side to resolve this. I do have USB charging turned off as well.

doh…that’s it! turn off the synch. i’d forgotten about that and thought i had to change settings on midi hub. thanks for getting me back on track

So I’m totally lost on the “turning off the sync” feature in OP-1. How do you do that??

Push metronome and turn green ccw

I would expect that the OP1 does not send midi clock when in sync mode. And I have not experienced that behavior. The rk005 works fine for me here. With Octatrack as a master and OP1 as slave. The rk005 also can filter some events. If i remember correctly.

So to confirm, turning off sync on OP-1 did the trick for me!! Bloody hell. What a pain. That was the culprit. Actually I confirmed that when sync was off, it did route midi clock via my box to the connected device. So all is well now. The $60 MIDIPLUS box works great now :slight_smile:

1 Like