Need help moving forward with Videolab on macOS Catalina

Hmm, the Videolab repo is pretty much dead/dormant for the time being. Can anyone help me get Videolab going on my system? I’m a developer, but not used to Unity. I’ve downloaded the latest Unity and tried several times with several versions of Videolab. Eventually I was able to sort-of solve my main issue (couldn’t use the imported assets) by dropping the videolab files into the Scenes subfolder of assets, but then I couldn’t use the Midi In/Out nodes in the patcher, they threw errors in Unity…all I want to do is just get started with development by following through the tutorial. Basically blocked at step 1… :confused:

Here are the issues in Videolab…


Cheers!

Not sure if you’ve tried this yet, but made a really simple Videopak template in Unity with instructions and download here: https://www.synthpaks.com/products/gif-looper-template-project-beta - It has videolab already installed. You need a specific version of unity though… it’s listed in the instructions. It’s a good way to mess around with a working project and see how I linked everything together…

Ah thanks, I’m aware of your project but I suppose I was thinking that I would go through the tutorial and then go to this and possibly other projects later…but this looks like it would be a good way forward now so I will try it this evening. Looks like you’ve done some really nice work here, much appreciated!!

1 Like

Once you get the hang of it, the possibilities are endless! I’m just scratching the surface with the little bit I can comprehend… I’m not a dev… just a lowly graphic designer. ha

1 Like

I just got this to work today. What worked for me was to make sure I was using unity 2018.4.x, per https://github.com/teenageengineering/videolab/wiki/Exporting-for-OP‐Z . I downloaded videolab from here: https://github.com/teenageengineering/videolab , built it and then exported the package. I think this is equivalent to having videolab-1.2, but this doesn’t seem to exist in the releases page for videolab. Then, I imported this package into VideoLabTest, and it worked.

I made sure to set the graphics api to gles2 for both projects. Some of the videopaks don’t work due to shader compilation errors. I think these were calls to gles3 that don’t exist in gles2.