OP-1 "Frozen" TEBoot screen

Hello everybody! My name is filippo and this is my first discussion here, nice to meet you all :slight_smile:

I have an annoying problem regarding my OP-1’s TE-boot screen mode:
when I boot the OP-1 up on TE-boot mode, I press any number key and nothing happens, everything seems stuck/frozen.
when I use the same numbers in normal mode (synth, drums, tape, etc.) everything works fine.
I tried connecting the usb cable to my imac, nothing changed. I actually tried quite every thinkable option…
as you can understand, this makes every kind of test/upgrade/etc. impossible to perform.

I already emailed the TE support about that, and they obviously told me to send the OP-1 to them, so they check it up and eventually (hopefully) repair it.

before going on with that option, I thought that maybe somebody in here already had the same issue and/or maybe someone has some good and useful hint to help me out with that.

thanx everybody in advance!


I made a video which could help understanding the problem :slight_smile:

I would guess the code responsible for the boot screen is corrupted, so that it freezes right after drawing that first screen. Strange issues have been reported latelly, with consequences that can only be fixed by sending it back to TE for reflashing. When did you buy your OP-1?

I bought it second hand on late january 2015, unfortunately no warranty left…

I also already changed the connection board using the ifixit kit. am I doomed? :slight_smile: