OP-1 won't power on

Hey there, so I got my OP-1 yesterday after 3 months of waiting and when I got it worked fine, powered up played around with it for a bit then I decided to update the firmware. I followed the instructions on screen and successfully installed the new firmware but now it won’t power on. I can still access the COM boot menu just fine but it just won’t do anything if I boot it up normally.

I have tried a factory reset, re-loading the firmware, fully charging it, just leaving it with the power switch on to see if it eventually boots up and have had absolutely no luck.

I don’t particularly want to have to send it back as I only just got it so I was hoping that someone on here might know of a solution.

Thanks in advance,

Current units already come with the latest version 220. The official OS update available for download is 218. AFAIK there are some incompatibilities regarding the bootloader from new units and OS 218.

See this topic:

Try (at your own risk) to install OS 220, link in this posting: