Op-z MIDI clock out lag

Hi all,

My experience so far using OP-Z with Oplab module to clock external hardware gear is a bit of a disaster. It works, but the lag is extremely annoying. I can easily send MIDI clock out from other machines (drum machines, for instance) to the same synths, no problem. But the OP-Z adds substantial lag to the chain. Am I missing anything here? Some weird config? Is it my unit? Should I try something else instead?

THANKS!

My OPZ oplab module as a master and CV into Moog Werksttat-01 and midi out to Korg Minilogue Module seems to sync fine. When I got my openlab module, I updated openlab firmware.
May be I have yet to encounter the same issue as you are facing when I start connecting more complex settings.

Maybe a midi echo problem? Have you checked all the midi settings in the module track settings?