OP-Z Midi Question

I’m having a problem with my OP-Z not sending out midi note data, but sending out clock. I have the synth I want to control set to the correct channel, and set the output channel of the selected track on the OP-Z to that same channel via the app, and I am not able to play or sequence notes on my external synth.
I thought this used to work but have tried all I can think of including removing and reinstalling the oplab module but still no luck with note data, just clock.

Any ideas would be helpful, thanks!

When connected to the op-z app, scroll over to Midi Setup and make sure Midi Out is enabled.

Thanks, yes the midi out is enabled.

Hmmm, not sure what the issue would be then.

good thing to do in these situations is to plug your device into the computer or even yor phone
and grab yourself a midi monitor app and see if its actually sending the midi
what channel, notes, all that info.

always helps me suss things out

Thanks I’ll give this a shot. This I guess will only tell me what it’s sending out over usb and not the oplab since I’m using the regular 5 pin midi to connect to my external synth.

Seems strange it would send the transport controls without issue but no note data which is why I assumed I have some setting wrong, but nothing I’m trying seems to be working. Thanks again!

ah i just assumed u were using the usb
if u have one of those usb to midi din jawns
u could use that to suss out the oplab module directly

i would guess that any midi that is sent out via the din port
would also be sent out via the usb port tho

I assumed that’d be the case too unless there was something wrong with my oplab. I’ll check it over usb tomorrow, thank you!

It’s been awhile since I used the opz to sequence but I think there is a track midi mute function? Can’t you more each track and enable them? Maybe you have it muted?

Thanks, this was it!
I don’t find it very clear in the midi manual or the section describing track parameters, but there were a number of tracks on the Card track that had been disabled. Shift tells you what is turned on, so all I needed to do was to turn back on those tracks with the card track selected and it works like a charm.
It would be great if this control was displayed somewhere on the midi settings page on the app since it’s a pretty critical midi setting.

Thanks again for steering me in the right direction.

Sure, I think that same thing tripped me up when I first got it, I couldn’t find an explanation either.

Where did this functionality go to mute/unmute midi tracks? Just installed the latest firmware and now shift on the module (now I/O track) doesn’t do anything when pressing the step buttons. I don‘t get midi out of my Oplab, only midi clock. It used to work fine prior to the firmware update. Where is the midi mute gone?

Hold the metronome button and the screen box button.


Man, you are a lifesaver, this works! Getting a reply within 15 min, this forum is gold. Is that change documented anywhere by TE?

You can find it in the manual in the midi chapter.
You can find the manual here: OP-Z guide: midi