OP-Z sampling problem

Hello everyone, I’m on the latest firmware. App doesn’t show visual recording feedback on the screen and it worked before earlier today. Any ideas?? Maybe do a factory reset?

(Just practicing for when this thread blows up for real in the near future)

1 Like

Oh, guys… justTROLLover it :slight_smile:

Remove and reinsert the sampling module, it may not be properly seated…

its a firmware update. JUST a mf firmware update. yesss

1 Like

but for real… anyone had any luck sampling with a line-in TRRS splitter? I got one and no matter what I do, the OP-Z only samples from the mic… I can hear the input of the splitter, but it does not record or sample from it. USB works great.

My confusion and hesitation to start getting more/different adapters is that I got one that was “verified” to work from different people and it doesn’t. Also, after looking around different forums, I see multiple people posting that adapter X works, then four other’s say it doesn’t, then another guy day adapter Y works, and then three more they it doesn’t work for them. Really confusing because TRRS adapters should all be wired the same.

no they are not. theres a few different ways they can be wired

1 Like

I see… that makes things more confusing. Still I don’t the inconsistency I’ve been seeing on forums on which adapters work and which don’t.

Hey @JohnnyEgo

I managed to get my hands on this adapter. It works flawlessly on my iPad, but my OP-Z just ignores it.

Connecting my headphones to the jack on the Mc CRYPT X-Port works though, but I can’t select the Line-In as input source for sampling.

Can you give me some advice on what to do? I’m on OP-Z OS 1.2.8

Thanks in advance and best regards


I’ve two of them and if I hold the screen button after plugging them in the nr 2 lights up as expected. you may hold it for 2 seconds to be recognized.

Hey, thanks for replying so quickly!

Live input seems to work just as you described it (no. 2 is lit up) and I can monitor the input just fine.

The problem I am encountering is, that when in sample mode, it doesn’t work anymore. To be more precise: I’m unable to switch inputs manually (in the manual it says shift + screen), but I’m always stuck on the internal microphone.

Does sampling work for you?

you have to press nr.2 to be activated and then change to sampling mode. keep in mind that it’s mono input. the mx400 is a mono mixer and works excellent with a few instruments at the same time, tested in this moment with Zelda on Switch (links awakening :drooling_face:)

image image

1 Like

Ah! Thank you very much. That worked for me!

I’m baffled though that the input selection shortcut doesn’t work on my device (in sampling mode). Even with no adapters/splitters, having only my headset connected, it doesn’t work for me to switch between internal microphone and headset microphone as said in the manual:

Do you have more luck than I do? :smiley:

that was with 1.2.5 and I guess TE haven’t deleted this from the manual! with 1.2.8 there’s just the screen and number combo!

this feature hasn’t worked in sampling mode aswell, you had to be clear beforehand like now. :innocent:

Ouf, that’s good to know! :smiley:

1 Like

Yes I just checked, that feature is gone. The new selection method is how you choose. If you have a apple headphone with mic you can press the mic button and it switches automatically.