Pocket Operator - Button Issue (no sound)

I’ve searched around a bit, but I haven’t found much info on this…
I have a PO-28 with a defective “1” button. It was working intermittently, but not consistently. I ordered a few SKHMQKE010 replacements, only to realize they’re not the same (specifically the plastic button seems to not fit). Fortunately, I was able to use the internal metal dome and keep the rest of the switch intact. Unfortunately, the next morning it wasn’t working again.
Curiously, pressing the button powers the unit on when it’s “asleep,” but it doesn’t consistently produce sound. I tried jumping the terminals on the top, and that didn’t output audio either. Is it repairable, or is there just some kind of internal short? I haven’t dropped it, pressed it hard, or had it in any adverse conditions, so I can’t imagine what’s wrong with it.
Is there any way to fix this or troubleshoot it?


I tried resoldering the contact points last night and it worked for like half an hour before it gave out again. The fact that it’s so inconsistent intrigues me, but I feel like it’s probably smarter to replace it than keep trying to fix it.