Samples to OP-Z without OP-1?


#1

Sorry if the question is stupid but how am I to add samples from laptop to op-z?
Official guide says to add them in OP-1 format. I tried converting .waw to .aif (which I think is the op-1 format according to google) and dragging the file to an empty slot in the fx track. Didn’t work.

Any suggestions?

If I add a sample to one of the synthtracks instead of drumtracks can I use the keyboard to play melodies?

Thanks.


#2

I haven’t tried adding sounds into my op-z yet, but I’m fairly certain you can use the OP-1 Drum Utility for Mac/PC to properly get them in the proper format… properly.


#3

The samples have to be specially prepared; the need to be 44.1khz, 16 bit mono aiff files and need special markers for drum or synth tracks. For drum tracks, you can use OP-1 Drum Utility or maybe the online tool at op1.fun (though I’ve heard of some problems about that). For synth tracks, I’ve written a little script to add the markers to the files, you’ll find it in my thread here on this forum.


#4

Will it be possible to transfer files directly from op1 to opz in the future? Or they mean that we must use computer to transfer between?


#5

^ Same for PO-33 using the OP-Z mic…


#6

Hoping they can add direct usb transfer with the next op-1 OS update. Or at least allow both op-1 and op-z to communicate through the iOS app… I only use my computer at home, but carry my phone and iPad all the time.


#7

Is it at this time possible to copy samples to the OP-Z from a iPad? Or will it come?


#8

Not possible yet. iOS13 is supposed to have support for USB drives so I’m hoping the op-z will be able to mount to iOS via content mode for file transfer and backup. Over on the Discord group an iOS13 beta user tried it and the op-z wouldn’t mount, but he said lots of usb drives were mounting fine so it might be a limitation on the op-z side. With sampling on the horizon I’m hoping we can transfer to iOS though, it would be really useful for sample transfers. We’re going to need some solution for rapid preset re-arrangement.


#9

Hey, I’m the user who tested!

It’s worth noting I was using an off-brand USB adaptor kit, so the official Camera Connection Kit may work fine. I suspect the issue may have something to do with the OP-Z not receiving enough power from the adaptor I have, but I’m not 100% sure on that.


#10

Oh cool thanks again - I’m tempted to try the iOS13 beta to see if I can mount the op-z via the CCK; was it hard to install?


#11

It was fairly difficult because I had to also install macOS Catalina. I would recommend holding off until the public beta, to be honest.


#12

It’s also super-buggy. Not worth installing unless you’re a dev, or you write about these things for a living.


#13

man showing up as a thumb drive would be longgggg overdue for iOS.

maybe it doesn’t identify itself as a thumb drive?
and rather like a hard disk or something?
i know the op1 was like that when i hooked it up to linux


#14

It shows up as OP-Z for a few seconds, then that disappears and a device called “XXERROR” shows up. It may just be a kink that will get ironed out by the time iOS 13 is out of beta, or it may be a weird problem with the OP-Z specifically that will require a future firmware update.


#15

Hard drives show up fine, not just thumb drives. Even the Octatrack works!

For the OP-Z, I get the same “XXERROR” error as @AliveThrouDeath.


#16

nice!
bout time apple started opening up their fucking OS