Videolab: Object appearing black when exported to OP-Z

Hey y’ll I received some great answers last time I asked this forum, and now I’ve got another Unity/OP-Z question/issue.

I created a disco ball in Blender, exported it to Unity as an FBX. Then applied a reflection probe following this tutorial. After that I added some lights, then patches, to control them with klak. And I think that briefly sums up everything in the project.

Here’s what it looks like in Unity:

But, when I export this videopak to OP-Z the Disco Ball is flat black, like OP-Z doesn’t like the Object or something. So it just looks like this:

The Ball seems to still be spinning in the OP-Z version, but yea, it’s totally blacked out. Has anybody had experience with this issue? Is there something I need to do to the blender object to make it more compatible? Or is this an iOS-app-v1.2-compatibility-with-Videolab-1.1…issue.

Really would appreciate any help.

Thank you,
Mustache Sweat

1 Like

I have the same problem with these videopaks:

They used to work perfectly, but I tried them today and all of them are messed up in a very similar way to what you show with your disco ball on my iPad mini 3 (latest iOS 12) as well as my iPhone SE (iOS 13)

So after building the project step by step and exporting to the iPad for each step it seems like the OPZ App doesn’t like the Metallic property of the material thrown on the ball. As soon as I turn it all the way up to one, the ball is pure black. With Material set to 0.5 the ball is visible but there’s no reflection of the point light, just the light actually lighting the ball.

I had problems with VideolabTest shaders when I tried them out. What worked for me was building videolab separately (with GLES2 graphics specified & on 2018.4.x version of unity, per‐Z). Then, I exported the package & used that rather than the 1.1 version from videolab releases in VideolabTest.

Interesting. Could you expand on the steps of this process, just because I’m still a Unity noob. I’d really like to test this.


  1. Make sure you have an install of Unity 2018.4.x.
  2. Get the videolab source code with git clone
  3. Open this Unity project, go into player settings and make sure Graphics APIs is set to OpenGLES2
  4. Click Assets->Export Package
  5. Export videolab into a file. This is what videolab-1.2 would look like, I think, but one hasn’t been released by Teenage Engineering.
  6. Now, import this package into your project with disco ball 2. Not sure if you’ll have to clear the old versions away if you already had videolab-1.1 imported.
  7. I think in your own package, you also need to make sure Graphics APIs are set to OpenGLES2.

I ran into problems also with what version of .net runtime I used. When working with VideolabTest, I had to set it back to 3.5. Going back to OpenGLES2 also caused a couple of the demos in VideolabTest not to work, as I think they assume a newer version of GLES. I’m also a Unity newb, so kinda just figuring this out as I go along.

There is a discord channel dedicated to Videolab/Videopak export and troubleshooting issues if you need further help with shaders, installation, export settings -