Arpeggiate the drum track

hey gang, i did this once a few weeks back and now i can’t get it to work. Any help would be great.

I used a aux cord to connect the midi out of the opz to the midi in of the opz (line-in module). Set the appropriate tracks in the midi settings to match. Then muted the arpeggio track audio (but not midi), and left the drum track set to a kit. This way each note of the arp track triggers a drum kit sound.

This worked the first time i did it. It was awesome as heck. I made some sick drum beats that i would have never been able to program in myself. I was planning on making a video about it but now i can’t for the life of me get it to work.
I tried to redo all my steps and i can’t get any sound…
any thoughts?

2 Likes

Oh man that’s an absolutely brilliant idea I’ve never even considered! I have a few thoughts, but the main one relates to how your MIDI CCs are set up from the Arp track.

My guess is that one or more of the parameters is sending values out to CC 1 or CC 2, which could either make the drum sound so high/low pitched you can’t hear it (CC 1), or could make the sample play in reverse (CC 2), which could lead to silence for short notes.

Similarly, if the Arp track’s CCs cause the drum track’s LFO to modulate CC 1/2 you’re gonna run into the same issue.

If this is the case, you could set the outgoing CCs from the Arp track to all be CC 0, which disables them. You could also pick CC 126 or something else not used by OP-Z.

Other possibilities off the top of my head:

  • Is MIDI echo disabled? When enabled it can sometimes cause a loopback that leads to silence
  • Is the Arp track definitely set to send MIDI to the drum kit’s channel?
  • Is the drum kit’s track set to a note style that isn’t retrig, such as gate or loop? It might just be playing such short notes you can’t hear them
1 Like

Just tried this myself, great trick! - I set the drum track midi ch to 7 and arp midi ch to 1, enabled midi in + midi out, disabled midi echo, enabled midi on both tracks, on the mixer I set the arp track to midi only (shift/red light), plugged stereo cable from midi in to midi out on the Line module. With midi echo on, it would either go crazy or silent, as James described above. I didn’t have any special CC values, maybe it also depends on the sequence you plug in the cables and adjust the settings.

It’s cool to record something on the arp track and then during playback adjust the arp range parameter to shift through the drum samples as the arp keeps hammering away.

2 Likes

Could also be cool to engage the master track to transpose the drum “notes” for even more variation.

I actually did this midi trick to send a bassline to the arpeggio track and have the two super tightly sync’d.

1 Like

My goodness the op-z is a non stop surprise device. Has anyone fully unlocked its secrets ? (Closest so far is windowbed I think)

1 Like