Backup OP-1 without PC?

Hi everyone,

this probably has been asked a couple of times before, is there any chance to get stuff off the OP-1 using an IOS device? I’ll be travelling shortly and I’d love to be able to offload my tracks to something which isn’t a laptop, because I don’t plan on carrying one.


Not an IOS device but an SP-404SX would let you sample into it for days

Yep, something like a Kingston Mobilelite Wireless G2 would do the trick.

ipad-cck-op1 works fine. just gotta find a file management app.

@masterofstuff124 Nope, that won’t work. iOS is very restrictive about what files can be transferred via the CCK (photos and videos).

An Android phone/tablet with USB OTG capability and an OTG adaptor should work fine.

jailbroken then maybe? i recall having no issues transferring files on my ipad 2 and my ipad mini 2. these days i use a windows tablet.

Within the Applesphere you can transfer files very easy (AirDrop), but not as soon as you enter the “Outer World”.

i tried it earlier today as i was curious. op1 > cck > iPhone.

kept saying device was not compatible or something after disk mode connected.
none of the file manager apps i tried were able to show the op1 disk either

i did read something about apple making their own file management app for iOS 11, so maybe things are changing?

Thanks everyone. I’ll take that as a challenge then. I’ll do a factory reset tonight and just see how far I get with what’s available.

I use a RAVpower file hub (SD card and USB storage).
Works nice for me with the free app.

no probs with android and a usb otg cable.

I have a jailbroken ipad but couldn’t get it to play ball

watch on youtube so you get to see the text overlay instructions popup and read the copy below video.

you just need something like an Apotop DW17, plug it into your OP-1 via USB. Load up the App on your iphone/ipad then transfer files to and fro.
You can save your files onto your phone/ipad or save them onto an SD card.

Im using this raspberry pi 0 setup. It helps if you understand shell coding.

That’s a really cool and useful project !

Im using this raspberry pi 0 setup. It helps if you understand shell coding.

@idellacraddock Thanks, that script looks useful! Now I have a good reason to get a pi 0… :slight_smile:

Ugh, if anyone knows a source with decent prices on raspberry pis in Japan please let me know. All of the places I’ve found so far are waaaay overpriced. (~$18 for a 0)

What are the main key features of a wireless card reader that will work with the OP-1?

There are cheap ones like Hizek (10 EUR) Meco (20 EUR) with different feature sets,or this RAVPower (40 EUR).

Which one will work with iOS?

I’m not able to get my Raspberry Pi 0 W to recognize the OP-1 in disk mode.

It must be doable, due to the existence of <a href=“” target="_blank" rel=“nofollow” style=“margin: 0px; padding: 0px; border: 0px; outline: 0px; font-size: 13px; font-family: “lucida grande”, “Lucida Sans Unicode”, tahoma, sans-serif; vertical-align: baseline; text-decoration-line: none; color: rgb(1, 115, 198); background-color: rgba(0, 0, 0, 0.05);”> I made sure that the OP-1 isn’t trying to draw power over USB, and I also made sure to use the correct USB port on the Pi 0.

would get a normal OTG cable. OTG to flat rectangle female, then plug the OP1 into that using a normal usb cable (mini to flat rectangle)

could be your adapter causing issues…? would suss that out first before you go any further.

i tried mine months ago w/ a pi 3. and it took a very long time for the op1 disk to show up the first time.
it was like 10-15 minutes or so if i remember correctly.
and instead of being recognized as a thumb drive like i thought it would, it was recognized as a hard disk.

then when i ejected it, it did some weird thing on my op1 and reinstalled all my patches or something.
it seemed okay after that, but i kinda didn’t really go too much further w/ the pi and the op1 disk mode after that.

I ordered an OTG cable, so I’ll try that. The connection itself definitely seems suspect. I’ll follow up when the cable comes. Thanks!