Best way to Loop Chops into the Drum Sampler without clicking?


I’m new here and wanted to say - awesome to be apart of this community.

So I’m a big fan of sampling right off my phone so I’ll be grabbing audio from platforms like Youtube. I’ve only had the OP-1 for a week so I’m still learning the best way to chop for myself.

I have noticed off the bat that when I record into the drum sampler and/or make a tape loop into the drum sampler, there are tons of chops that do not start or end at zero crossing. I’ll compensate by moving each chop until it is at a zero crossing but it leads to a some pretty big overlapping when I use the Endless sequencer… I seem to hone in on the BPM as close as possible but just not getting the results I’d expect if I did the same in Ableton’s simpler / sampler (might not be the best comparison lol)

Does anyone have ideas on the best way to eliminate the clicks when sampling? I’d love to get as close to a perfect loop as possible!

1 Like


One thing that helped me was to set the trigger to one shot. (Red knob —->|)

It’s not the perfect solution but I think it helps.


Hey Robert,

Thanks for the tip!

I experimented with both one shot and holding the notes to the end of the sample (->). I think with most samples I’ve tried, the zero crossing for some chops drastically overlap with the previous or next sample chop so performing with strictly one shots lead to weird offsets when sequencing.

My gut feeling is I just need to very creative such that it may be a whole mixture of using different trigger modes and making sure the zero crossing overlaps well across chops. Something I’ll just need to keep practicing as I sample more… every sample will give a different result I suppose :slight_smile:

1 Like

Maybe tweaking the envelope for the sample will help…

1 Like

Thanks Laotzsa, the envelope isn’t quite what I want. I’d love to add a little attack to each sample chop but I’m using the Drum Sampler which seems to have 1 dedicated envelope that isn’t a standard ADSR one.

Pls correct me if I’m wrong!

1 Like

If you make the chop really small by bringing in the end point, it zooms in on the sample for a tighter chop. Once you no longer hear a click you can bring the end point back out (& vice versa) & once I learned this I never had a pop/click in my chops again.

Sometimes it takes time to find the exact point where there isn’t a pop/click & some sounds are harder to get a perfect chop than others, but if you are willing to take the time you should be able to get a chop without a pop/click by zooming in on it.

Good luck!

  1. clicks come from the edge samples being at a “vertical” offset to each other. if you can’t have enough control over the loop points, then try taking out some of the bass of the source sample since that’s what keeps the waveform away from zero for longer periods of time.
  2. often clicks disappear once you add other elements of your mix. don’t rely on this but don’t obsess over clicks either. it’s the op1 sound

Thanks everyone! I’m getting much better results now.

My current way to eliminate obvious clicks is holding shift when setting the start / endpoints, if there is a click on the chop. This provides a much more smaller offset so you can really hone in on each point… didn’t know you can do this at first. I do my best to use my ear instead of zooming into other marker, so I don’t have to worry about messing up the loop.

It’s great that there’s so many different ways to achieve this though. Hope this helps someone too!

1 Like