Bricked OP1

Hi guys, i am new here, though i´ve been using my OP1 for a couple of years.
I started having trouble when i got a new notebook (an i7 running Win10) because it never recognized my OP1 (running OS 14167)

That´s when the nightmare begun :

I tried many different USB cables (including the original one) on every available USB port but no connection established (no USB hub was used, all connections were direct to the laptop)
I tried with my old laptop (HP 505 running XP) and no luck
I tried doing a factory reset on the OP1 and nothing changed.
I tried formatting the internal drive on the OP1, and it fucked everything up : although i can still get to the bootloader (shift+COM on power on) no firmware can be updated since no USB connection can be established (pic 1)

when i try to do a standard power on, the display shows some booting mistake and the OP1 is frozen (pic 2)

Of course i contacted TE and fortunately they answered pretty fast.
Unfortunately all they seem to be able to recommend is sending the unit to RMA, (which in my case, living in Uruguay means it´ll have to go through the vultures @ customs twice)

Does any of you have any suggestion ?
(turning my OP1 into a paperweight is not a option)

This is the screen when i boot the OP1 :

you’re best bet might be to send it to them unfortunately. at least you’ll get it back all frisky n shit

hope u get it sorted. this type of shit is never fun