Can't change octaves in midi mode after 241 firmware update

Came with 239 and everything worked great with the midi controls. Was able to go up or down octaves in midi mode. That was just with the midi mode not with having it be a control surface in Ableton. I upgraded to 241 and for some reason that didn’t work anymore and I’m wondering if anyone has any help for that?

In the manual and they were saying how you could make the OP1 a control surface to use with Ableton. I went support website https://support.teenage.engineering/hc/en-us/articles/360009776480-OP-1-controlling-Ableton-Live and downloaded the GitHub link (I think I did. It’s so unclear. And there wasn’t anything to unzip. Just some python code and some README thing and a manual for what the controls would be for in Ableton. I did what it said and and put the files in the app resources file of Ableton, selected it as a control surface, and it doesn’t work do anything other than play the keys it has. No ability to go up or down octaves. I’m using Ableton 10

2 Likes

(Hey there! I think I replied to you on reddit too!)

So, there are two different issues:

  1. The octave thing is an actual firmware bug, it doesn’t happen just with Ableton. By the way you don’t really need the Ableton script to use the OP-1 as a standard MIDI controller, only if you want “smart” features like automatic controller assignment. Personally, I don’t use these features. I think they tend to get in the way instead of helping.

  2. Looks like the control scripts are outdated and only really work on Live 8 (at least according to the documentation on Github). Looks like someone dropped the ball on software management! Doubly so if you consider the octave bug. :disappointed:

I’ve the same issue in Reason. I did the upgrade and now octave switching doesn’t work anymore for me, too. I send a mail to TE, hope this will get fixed soon. :confused: Also made a twitter post about this to TE.

Edit Did a downgrade to 237 and is fine now for me. You can find older versions here: http://oper8.free.fr/op1_os/

1 Like

Ok so I’ve been doing some sleuthing lately. My Op-1 came with version 239 as well. There are 3 ways you can get MIDI into Ableton 10 as far as I can tell. But I still can’t get octaves to work in true MIDI mode (OP1 as control surface).

Well first of all, the Teenage Engineering scripts don’t work at all with Live 10. The GitHub for these scripts point you to a fork which actually does work mostly as advertised (octave keys excepted) for Ableton 10. https://github.com/pcppcp/op1

Note the release is from the “live-9” branch but the original TE scripts are from “master” so maybe that’s an issue… haven’t tried building the TE scripts from the live-9 branch.

  1. “OP-1” Mode. This is the normal mode that you play in, but if a USB cable is connected, the OP-1 constantly spits out MIDI. In this mode, the left and right arrows shift octaves while playing. The MIDI data output is actually shifted notes… so say you were playing C4. If you hit the arrow key you the notes output by the OP1 changes by one octave (so C6 or whatever I can’t remember but it actually prints out a different note). This will happen if you have the OP1 set as a control surface or just as an input.
  2. “MIDI” Mode. This is the mode where you do shift+COM + 2 and the OP1 displays midi mode on the screen. If you get into this mode, the OP1 outputs the control command Pan (fine) 127 followed by Pan (fine) 0 for right arrow and “Controller 41 127” followed by “Controller 41 0” for left arrow. No matter what you do with the left and right arrows, the note values sent by the keys do not change.
  3. “Control Surface” Mode. This is the mode where you do shift+Com + 2 and you have set Ableton to recognize your OP1 as a control surface in the MIDI preferences. Here, you can have fun using the play and record buttons to control live as well as the metronome and all that stuff. HOWEVER still no dice on controlling the octaves… you always send the same MIDI note on/off, and the arrow keys send the same sequence as #2 above. (Note that this is in PERFORM mode of the script).

Anyway sorry if this is confusing, but in summary I can’t reproduce octave shifting in MIDI mode even with 239. I suspect @lezgetit87 was just in “OP-1” mode and not actually in MIDI control mode when they got the octave thing working. Though I’d love to be proven otherwise.

I might give 237 a try since @aquil331 had luck with that one on Reason, and I believe that for the octave to actually shift in Ableton the unit has to do the octave shift itself and send different notes (unless Ableton itself has something that maps an octave shift to a key… in which case it’s a script error and is easily fixed).

Ok I tried to go to 237 but it wouldn’t boot on my OP1. I suspect it’s not compatible with the newer batch of OP1’s after the redesign but who knows. I tried to install it twice to no avail and ended up on 241 in the end anyway.

At any rate, it seems like I can change octaves if I use “OP1 Mode” as has been reported elsewhere even if I can’t control the rest of Live in that mode. Annoying but whatever life is short.

For reference, this is the output of my MIDI Monitor (Mac OS X):

OP-1 MODE (SHIFT+COM then 1)

00:41:31.606 From OP-1 Midi Device Note On 1 F2 127

00:41:31.720 From OP-1 Midi Device Note Off 1 F2 64

00:41:32.703 From OP-1 Midi Device Note On 1 A2 127

00:41:32.829 From OP-1 Midi Device Note Off 1 A2 64

NOTE HERE I PRESSED THE OCTAVE SHIFT

00:41:35.220 From OP-1 Midi Device Note On 1 F3 127

00:41:35.315 From OP-1 Midi Device Note Off 1 F3 64

OCTAVE SHIFT AGAIN

00:41:38.352 From OP-1 Midi Device Note On 1 A4 127

00:41:38.512 From OP-1 Midi Device Note Off 1 A4 64

SWITCHING TO CTRL MODE (SHIFT + COM then 2)

00:41:41.158 From OP-1 Midi Device Control 1 Expression (fine) 0

00:41:41.792 From OP-1 Midi Device SysEx Universal Non-Real Time 6 bytes F0 7E 7F 06 01 F7

00:41:41.863 From OP-1 Midi Device Control 1 Effect Control 1 (coarse) 0

00:41:43.376 From OP-1 Midi Device Control 1 Balance (coarse) 127

00:41:43.459 From OP-1 Midi Device Control 1 Balance (coarse) 0

00:41:43.775 From OP-1 Midi Device Control 1 Channel Volume (coarse) 127

00:41:43.859 From OP-1 Midi Device Control 1 Channel Volume (coarse) 0

SOME NOTES

00:41:49.181 From OP-1 Midi Device Note On 1 G3 100

00:41:49.327 From OP-1 Midi Device Note Off 1 G3 64

00:41:49.454 From OP-1 Midi Device Note On 1 B3 100

00:41:49.572 From OP-1 Midi Device Note Off 1 B3 64

NOTE THE FOLLOWING ARE OCTAVE SHIFT PRESSES

00:41:51.322 From OP-1 Midi Device Control 1 Pan (fine) 127

00:41:51.433 From OP-1 Midi Device Control 1 Pan (fine) 0

#NOTHING HAPPENS AND WE SEND THE SAME NOTES

00:41:54.492 From OP-1 Midi Device Note On 1 B3 100

00:41:54.632 From OP-1 Midi Device Note Off 1 B3 64

00:41:54.768 From OP-1 Midi Device Note On 1 G3 100

00:41:54.864 From OP-1 Midi Device Note Off 1 G3 64

00:41:56.570 From OP-1 Midi Device Note On 1 G3 100

00:41:56.690 From OP-1 Midi Device Note Off 1 G3 64

00:41:56.748 From OP-1 Midi Device Note On 1 B3 100

00:41:56.863 From OP-1 Midi Device Note Off 1 B3 64

Doing some more archaeology, I ran across this:

https://muut.com/imaginando#!/imaginando/op1:op-1-control-surface-live

which suggests that the behavior of the arrow keys while in MIDI mode is selectable via the white encoder. It seems like in older firmware when selecting the keyboard +/- icon instead of “MIDI CC” then the arrow keys will behave as they do in OP-1 mode… but I can’t load an older firmware to verify bc I have a newer OP-1.