Custom Firmware on the OP-1


#701

@wavi what presets did you use for iter? Did any of mine make the cut? I haven’t had a chance to install the update yet.


#702

I added every iter patch that was on op1.fun at the time. That includes the following 11 patches (I had to lowercase the names since the OP-1 does weird stuff with uppercase characters, see this post Custom Firmware on the OP-1):

  • crystal_pad
  • ebullition
  • feu_doux
  • iter
  • korder
  • lotremkords
  • pulse_bass
  • rezpiano
  • wonky_bass
  • wood_bell
  • woodblock

The tool simply contains the aif patch files. To enable the presets it reads the patch data from the files and writes the data to the presets table in the database.

PS
There’s still space for 5 more presets… You all know what to do :wink:


#703

Lotremkords and korder are mine :rainbow::crown:


#704

Little help please

can’t install op1repacker in python3 PC. syntax error. where does the repacker folder need to be located for python to find it?

would it not be super easy if someone just posted the latest repacked custom firmware file?


#705

Can you provide a little more details on how you tried to install it?

You shouldn’t have to place the op1repacker code anywhere manually. Instead running the installation command should download and install the latest version on your computer:
pip3 install op1repacker

I’m not providing modded firmware files since that has copyright issues and also makes it impossible to choose what mods you want.


#706

ok. i open up python. at the dos type terminal i type in the command as per the instructions and get syntax error. the zipped and unzipped op1repacker file and folder are on my desktop.

repacker


#707

Ah, you’d need to use the normal windows terminal / command line instead of the python interpreter. Then the installation should work.

EDIT:
So basically open the start menu, search for cmd and from the results open “Command Prompt”.
Once you’ve opened that try running the installation command:
pip3 install op1repacker

That should install the tool, and once it’s installed you should be able to run the op1repacker commands that are in the readme. Let me know if you have more questions. I’ll try to write a windows guide eventually, but I don’t have windows so it might take a while…


#708

well…nope…
repacker2

uninstalled python3. now reinstalling python3.

will post back with results


#709

All good. custom firmware up and running . thanks


#710

Awesome! So I guess reinstalling python fixed your issue?

Since I’m not on windows could you let me know which installation command ended up working for you? That would help me write a guide for windows.


#711

python3 stand alone installer.

pip3 install op1repacker did the trick