DBox with finger sequencer polyphony?

Trying to replicate a sequence I made on the OG OP1 in finger sequence, and for some reason although I entered more than one note entered on steps, it is coming out with just one note on those steps. Is there something about DBox on OP1f that is causing this? Polyphony seems fine with the regular old sample drums, and again this sequence worked on the OG. Perhaps something about how I replicated the DBox sounds in the OP1f kit?

On my unit the polyphony seems to work fine with Finger/DBox. Did you try loading different DBox patches?

I have tried different patches now. What seems to be happening is that there is no polyphony between notes with the same “mode” (big red dial). This seems to be a change from the OG, as there was not any highlighting(quantization) of the mode, so perhaps while the same idea was at hand, there were as many “modes” as there were positions on the dial. Try creating two notes with the same mode and let me know if you have the same issue. So far I’m finding this very disappointing and frustrating. Any TE folks able to chime in here?

An update from TE:

i see now what you mean: we checked, and the dbox engine was actually not behaving as intended!

we adjusted it, and this will already be fixed in the next firmware release.
a big big thank you for bringing this to our attention!

1 Like

It appears that the new firmware (1.4.5) is already out, and the problem seems to be fixed! That’s a TAT of mere hours! Greatly appreciated, though perhaps gives me a bit of pause with respect to testing…