Does anyone succeed to restore his user presets after changing unit or factory reset?

I changed my op-z because of double trigs and now when i try to restore my backup, i can’t have my presets back. By presets i mean the settings you save the white keys (track + holding white key).
I tried different backups, different firmware versions, the method of electrafa

Yes, you can’t import the userPreset.dat if there’s not already one. so after a factory reset you need to save at least one preset, the OP-Z will create the userPreset.dat and you will be able to overwrite it

If you have ideas to help me you are welcome :grin:

Well, answer to myself… “resolved”
it’s looks like there is a problem about the redmountpack when restoring backups, i had to transfer it via the app otherwise the slot was empty. Once i restored every packs via the app, and restored the backup, still no user presets on the white keys. So i dit the technique above (after a factory reset you need to save at least one preset, the OP-Z will create the userPreset.dat and you will be able to overwrite ). Didn’t work… but previously i saved on my computer the userPreset.dat (freshly created). So what i did on my op-z was overwrite it with my old userPreset.dat and re-overwrite with the one on my computer.
Get back my presets
Love the op-z but pain in the ass sometimes


I had to dig to find this post, I had the same situation, TE replaced my OP-Z because it would intermittently not connect with the Line Module when it started up. I restored my backup from before I shipped it and I was able to play all synth tracks, but NO Drum tracks. All the sound folders were dead. So I did what you recommended and created a preset and deleted it and it slowly brought back all the drum sounds. I also turned it off and back on to hopefully hasten the process and solidify the drum track sounds. I have had to do a various number of other factory resets on my OP-Z, before replacement and after, when I leave it plugged into my MacBook Pro, which is 99% of the time, sometimes when I turn it on, it goest straight to update mode. I turn it off and back on, still no change, unplug and replug in, still the same. Different cables, nothing works. Starting up with P or T button held, no change, still goest to update mode. So I have to remove the battery and put it back in, and then it starts working again, but sometimes removing the battery causes it to factory reset. This other issue I have not determined what is causing it, but at least now I know how to fix the preset issue better when it does. Thanks for your post.

Glad it helped :wink:
Yeah there are some bothering issues sometimes…
Have a nice day !