Dr. Videolab and the Multiple Versions of Unity of Madness

Hello everyone! I am a happy OP-Z owner since a few months, and I’m in love with it. I am a motion designer and I was intrigued by the Videolab capabilities from the start, but I managed to find the time to set up the Videolab environment only yesterday. I’m a complete Unity newbie so it took some time to understand the system. After a good deal of trial and error I’ve managed to get the latest recommended version of Unity running (2018.4.29), along with the Videolab 1.1.3 Beta on an M1 Mac mini running Monterey 12.2.1.

I tried to follow the simplest tutorial out there: rotate a cube with a knob, but I could not manage to do it and after a full day of experiments I’m out of ideas.
First things first: I’m connecting the OP-Z via an apple USB C to C cable directly into the Mac mini, MIDIjack shows the OP-Z as input and output and I can monitor the MIDI messages in its little window.
So far so good.
I created the cube, created the super basic KLAK patch (Knob input > Axis conversion > Transform out), assigned the transform out component to the Cube… and nothing. Nothing at all happens. Not in the editor window, not in the Game window.
There is some contradicting info about the need to create a MIDI source component: some say it’s not necessary because MIDIjack captures everything anyway, but just in case I tried with and without it. No results.
I also imagined that maybe it’s not possible to use OP-Z directly into Unity, so I managed to successfully export my sad Videopak into the macOS OP-Z app (v1.2.20) and the cube shows up, but there’s no interaction with the knobs. I’ve tried to export both the Videopak without the MIDI source (as recommended someplace in the wiki), and with it. It made no difference.

After this flop I went back and installed an older setup to see whether it was possible to replicate 1:1 some of the tutorials I’ve seen online, so I grabbed the 2018.2.21 version and the 1.1.2 Videolab package (I believe from one of Cuckoo’s tutorials). Again: MIDIjack seems to be reading the input correctly, but I could not find a way to make the thing rotate into Unity.

What am I missing?
Any help appreciated!

1 Like

As usual getting away from a problem makes you see some path forward. I left the thing alone for a while and came back at it today, approaching it step by step. First I forgot about the OP-Z completely and built a patch that would transform (uniform scale 10x) the cube with a mouse button press. That worked.
Then I connected the OP-Z and swapped the mouse button input with a note input from the OP-Z (without bothering with the MIDI source at all: it catches everything anyway). That also worked.
Then I moved onto the next step, and tried to build again the Knob input / Axis transform / Transform Out (Rotation) patch. No dice.
Seems like I’m missing something maybe in the conversion from the Knob value to the rotation, or for some reason the knob input stopped working on my particular setup (seems like operating system might be relevant as well), and since the MIDIjack code is not maintained anymore it will never be fixed.

Does anyone have a configuration where the Knob inputs are working properly that can share it?
Or a working patch with Knob input that you can share for testing?

Thanks for any input!

Well, all’s well what ends well: I finally found the culprit!

Turns out you have to specify the Knob number in the “Knob input” inspector pane. The OP-Z knobs are 1-4, and any other value doesn’t work. The default is 0.
I’m pretty sure I tried changing that number to 1 in my feverish attempts yesterday, but evidently I was messing up something else.

Great to know that I have a working setup, at last!