How to connect OP-Z to MicroFreak?

OK I just got a MicroFreak to compliment my OP-Z. The MicroFreak sounds crazy.

I read from @Xander and few other posts on the internet that he connected they two through USB (and then could chain other synths through that).

I have the regular TE USB C to USB A cable, but the MicroFreak only has USB B input.

Do I just need to get a USB C to USB B cable like this link below?

Or do I need some kind of USB/midi hub thing? I hope I don’t.

Thanks for helping out a new person to this.

u should be able to use just a USB cable to link them up

however, the cable u linked, the B port has an extra hump on the top
thats not gunna fit the regular B port on the microfreak

u want one with a regular B port basically.
just make sure the cable does data too and not just power and u should be good to go

Well spotted! And thank you for confirming. I plumped for the below one which even mentions compatibility with midi controllers.

Hey @dhunterrr,
Yeah so I used a USB A to C adaptor (just one that came with my phone) to plug the microfreaks USB B to the opz. I then used a standard midi cable (and the included 3.5mm dongles) from the output/thru port on the microfreak into another synth (model: cycles) and was able to run them both from the Z. Takes a while to get it working, it’s really janky setting up midi from the opz, I’d use the app to make sure the cc channels are set up correctly. You need to also adjust the midi on the other gear so that they align. Hope this helps, let me know if you get stuck with it

Thanks so much. My cable arrived and I’m gonna give it a go… :crossed_fingers:

2 Likes

Well I got the MicroFreak sequenced from OP-Z on channel 14 or 16 fine, but midi thru to a korg NTS-1 doesn’t work.

I think the cable is fine as I can play the NTS-1 on the MicroFreak keyboard, so something in the settings.

I’ll be trying again later and will report my settings that do/don’t work…

OK, here are the settings that kind of work.

With the below I can sequence the MicroFreak on channel 16 and play it from the key buttons on the OP-Z. But midi through to korg NTS-1 on channel 14 does not work.

OP-Z
In midi setup on app, I have default for all CC (I’d don’t understand those) and all global options switched off except midi out and clock out. Each track does have the correct channel number assigned.

MicroFreak
Utility - midi…
Input chan: 16
Output chan: 16
Output dest: both
Thru: on

Utility - sync…
Source: midi

If I set the source to usb/auto the pattern starts automatically and the OP-Z stop button just restarts the sequence!

It is noticeable on any source setting MicroFreak sequences don’t play properly.
Source : int : pattern triggers first note and stops
Source : usb : sequence does play but pattern can’t stop, as above.
Source : midi : pattern plays but no sound from MicroFreak
Source : clock : same result as midi
Source : auto : same result as usb

I might be making a silly mistake but otherwise I’m not sure if it is an OP-Z issue or a MicroFreak issue not sending on the midi data to NTS-1.

Any detail on other people’s settings to work are appreciated.

Hmmmm it appears the microfreak is getting both channel 14 and channel 16, so I think it really is not working at all well.

When I last bought synths 15 years ago there weren’t these issues. Connect a midi cable, set a channel, no problems!

plug your shit into your computer or phone // tablet
get a midi monitor program or app
see what is actually going on
what midi messages are being sent and received

always helps me a ton to suss out midi things
instead of just guessing what u think is going on.

Thanks so much, great suggestion.

I downloaded Midi Monitor for Mac. It looks to me like everything is fine from the OP-Z notes are triggering from the right track. The only issue I had (which explains the doubling of channels I got before) was that OP-Z track 14 was mapped to track 16 as well, so both tracks were firing in the MicroFreak when set to channel 16.

I still have the OP-Z set to only send midi and clock, not receive.

If I plug the MicroFreak into Midi Monitor then I get nothing if I play the keyboard or twiddle nobs. Doesn’t matter what sync settings I use.

So I’m left with two scenarios at the moment…

MF utility>sync>source = usb/auto : can’t stop a sequence on OP-Z, it plays automatically and pressing stop just resets it. With this the MF arpeggiator and sequencer seems to work.

MF utility>sync>source = midi : OP-Z starts and stops sequences, notes come through to the MF but if I switch on the arpeggiator/sequencer it makes no sound.

So my guess is either the OP-Z can’t help but listen back to the MicroFreak in some way, which it shouldn’t, or something is up with the MF.

Weird, and a bit disappointing. @Xander did you have anything like this?

Thanks

1 Like

Good news—I updated the firmware on the MicroFreak (probably one of the first things I should have done) and it seems to be working ok now! I’ve even got midi thru to the NTS-1.

On the MF I have Sync>Source set to Auto, although if I have the arp switched on and hit a key on the MF or on OP-Z (and the track that send the midi channel to the MF is selected) that sets the OP-Z sequencer off which is weird. That happens with any Sync>Source setting. I can handle turning on and off the arp though.

Much happier.

Thanks for all the support.

1 Like

Hey @dhunterrr, sorry didn’t see your message, glad it’s all working for you now! Weird that the sequencer is turning off like that. I do remember the first time I tried setting these units up that MF would do something similar to the Z. The Z is definitely pretty finicky with it’s midi.

Thanks @Xander it all seems to be playing well enough at the moment. Thanks for your help/

I have tried hooking up an old drum machine (DR 660) and got it working but it seemed to drift a bit, but that is for another thread…