I sent my OP-1 to a private repair shop (need Advice)

I bought my OP-1 used and it had the famous Firmware Bug: it was impossible to Boot Info TE-Boot mode. That meant that updates or resets were impossible. The OP1 worked fine like that for me, but the firmware lacked all of the new features since 2012 and that sucked.

I sent the OP1 to the German Servicecenter Siedler in Neuss, because somewhere on the OP1 Forum people recommended it.

After sending it in and waiting two whole months, they sent me a cost estimate of 400€. Not only do they have to flash the Firmware, they also have to install a completely new DSP Board…

Is this really necessary? On the Forum it said only a firmware flash was necessary… The OP1 worked completely fine with the old board… Should i do it or decline?

1 Like

I guess you should try the same as the OP here: https://op-forums.com/t/well-im-sad/20356/4

how to fix the “no te-boot” issue:

  1. start OP-1
  2. connect usb
  3. enter disk mode: [shift] + [com], [T3]
  4. recommended: backup the files from OP-1 to your computer.
  5. drag and drop “te-boot-fix.op1” onto OP-1 removable drive
  6. eject OP-1
  7. restart OP-1
  8. allow update and then turn off OP-1
  9. hold [com] and start OP-1
  10. update with latest official firmware as usual
  11. enjoy.

hope this works for you. thank you for your patience.

teenage engineering support


1 Like

ive been back and forth with support emails, and Instagram… with the same issue with an out of date op1, that i can’t update cuz no boot menu… unfortunately for me… this “Fix” did not work for me, but im sharing in hopes it maybe does for you.

Thanks for that, I hope it may help others…

I am also planning to use this “te-boot-fix.op1” because I cannot use TE-Boot mode in the same way. However, since I can’t even see the display, I don’t know what to press for permission in step 8, so could you please tell me?
I can mount op-1 in disk mode, so I’m thinking I can use it.

I‘be had the same problem. I suggesting contacting TE support. I’ve had to send mine in to get the dps board repaired.
Just got it back and updated. Happy. But I’m sorry for you.
Good luck.

The “boot fix” did not work for my previous version My op1 was currently at.