iOS 14.2 + OP-Z app problem

Just updated my iPad to iOS 14.2 and when I connected the OP-Z, the app wouldn’t switch away from the initial screen no matter what I pressed on the Z. If you were thinking about updating, you might want to wait and see if a fix for the app comes :frowning:

2 Likes

Thanks for this. Updated my iPhone, but holding back on my iPad until the issue is sorted.

It does appear to be on the OP-Z app side as opposed to either iOS or the OP-Z, as I’ve tested another BLE-MIDI app (MIDI Scope) successfully with my iPhone updated to iOS14.2 and my OP-Z.

CB

Sadly I updated both my phone and iPad before discovering this. I looked on the TE website to see if there was a way to report this, but came up empty handed. Anyone have an idea of an email address to send this to?

if u click support portal on the website there is a link to send a support ticket

seems like everytime either side updates, the connection breaks.

luckily it still works with a USB-C cable

You’ve got an app which is core to your business and that your customers rely heavily upon, so you are active in the Apple Developer Community and perform regression testing upon your app as soon as iOS beta releases become available…

Or you’re Teenage Engineering.

CB

1 Like

hey guys, thanks for picking this up. we have had several reports of this as well as reports from other app developers. we’re working on it…! as you point out @freqout, the current workaround is using a cable. thank you for your patience and have a good one for now!

4 Likes

A further question and an observation…

Have any of you successfully connected your OP-Z app via bluetooth after updating your device to iOS 14.2?

We’ve all discussed the longevity of devices such as the OP-1, and we’ve seen some users buying in spares kits to head off future problems and try to make their OP-1 a “device-for-life”.

We’ve also seen discussions about the comparative merits of the OP-1 inbuilt display vs the OP-Z offboard app.

Given the lack of testing by TE to avoid recurring integration problems, and given their lack of any resolution a full week later, what will that mean for the longevity of our OP-Zs once TE inevitably further lose interest in it?

Looks to me as if, in the not too distant future, we will have to retain an i-device at an old iOS version for ever, in order to keep running the OP-Z app. (I know there is always the OP-Z button/led interface, but I’m sure lot’s of us rely on the app to refresh our memories after periods of disuse)

Views?

CB

actually since posting that, my experience with the cable has mostly been bad. a lot of the time it won’t be recognized at all. the other day i finally had it working, but i needed to change some midi CC assignments and it would instantly crash as soon as I changed any of the values.

exactly what i did! i dusted off an old iPad Air (1st gen) that is still running iOS 12 and I’m running just fine again.

The cable doesnt work well (as pointed out by freqout). sometimes it worked, mostly only for a short while.

Why would this not have been picked up in (even very rudimentary) testing? In the context of this app, failure to connect is pretty hard to miss.

Should we be worried about TE’s ongoing commitment to support OP-Z and iOS?

CB

Orthoplay iOS remote won’t connect anymore either. Anyone else have problems with OD11?

It is working for me. I haven’t tried it with bluetooth, though

Hi! after 14.2 update i can’t use it even via cable, it crashes every time after a few seconds. i can send you the crash logs if it helps

Luca

Hey guys - I saw elsewhere that if you get the Beta 14.3 iOS update it fixes the Bluetooth connectivity - and so I tried it this morning and I can confirm that works! It’s pretty easy to sign up for the Beta program and you just need to install a beta profile on your iPhone - which was very easy - link here https://beta.apple.com/sp/betaprogram/ - obviously this iOS will be officially released soon but it seems to be working well and you can get now… so get on it guys :slight_smile:

3 Likes