Issues controlling OP-1 with MIDI Controller (Push2) in Ableton


I’ve been controlling the OP-1 in Ableton using the Push2. I’m having an issue where the OP-1 is working just fine with the Push2 and then suddenly stops receiving MIDI messages from Ableton. I can trigger notes with the OP-1 keyboard, but not the Push. It works again if I restart the OP-1, but this is a pain to have to keep doing. I switched USB cables and it seemed to work better, but it is doing it again today. It’s not just the Push as I have tried it with a Keystep, and the same thing happens. Ableton is still sending out MIDI messages.

Sometimes it’s precipitated by an event such as adding a MIDI effect to the track, sometimes I can’t tell why. Is the OP1 getting overwhelmed with too many MIDI messages? I have been researching and trying to solve this for a couple of days now, but can’t find anything directly related to this issue. I’ve also tried it with both USB audio and line out. OP-1 is set to MIDI channel 16.

Has anyone else experienced this? Any ideas on how to fix it? Any help would be super appreciated as otherwise I love this combo.

Thanks for your help and time. This is my first post, I love this forum. <3

i’ll say that the OP1 MIDI implementation is def not the greatest or most robust.
it wouldn’t surprise me if it was possible to overwhelm it with messages.

maybe PUSH (or KEYSTEP) // ABLETON is sending some sorts of extra midi messages that u might not be aware of?
maybe some weird like sysex messages or something that the OP1 does not like?

not sure just throwing out some ideas

have u tried doing a factory reset and seeing if that helps?

Thanks for taking the time to help. I just downgraded to OS-242 and the issue is seemingly fixed. I’ve tried everything I could to overwhelm the OP-1 with MIDI input messages, and still not having a problem. It’s a bummer to lose USB audio functionality, but much prefer to operate like this.

I’m a pretty new user and just started messing around with it in Ableton after the new update, so I had nothing to compare the functionality to. Thanks again.

1 Like