Issues with USB functionallity

Hey
Had my OP-z for a year now. Haven’t used it much the past 6 months.
I’ve started playing with it again and now it seems the USB port isn’t working anymore.
No connection to the PC, so i can’t access content or upgrade mode.
I used to be able to play with my keystep directly connected to the OPZ, now no MIDI seems to go through.
It charges the battery, so that works. And everything else about the unit seems to work fine, but the USB-port data i/o isn’t working at all.

Really sucks not to be able to use content mode to backup projects, or upgrade fireware, or use it with the computer or other gear.

Is the USB-port faulty?

Did you try different usb cables? Cleaned the USB-C connector on the OP-Z from dust? Tried different USB ports on the PC?

Yeah i’ve tried different cables, usb ports, and two computers. Will try compressed air into the port, but don’t think that is the issue. Something is up with the unit i think.

Ok, and you haven’t had the USB-C connector plugged in to the OP-Z when you power it up?
Factory restore is one option that might help, but then you do lose all content.
Else changing the USB-connector plus flex cable could be a possible fix if the problem lies there.
That’s all i can think of, but hopefully somene else comes up with an easier solution for your problem.

Are you connecting it properly ? Hold track, power up and THEN connect to PC.

I have been having the same exact problem. Were you able to find a fix?

I’ve been having the exact same problem. CONTENT mode isn’t working with my OP-Z. Tried different cables, 2 different computers, it doesn’t work on my Macbook Pro (2010) nor my iMac (2016). However, it DOES work on newer Macbook Pro’s 2017 and up instantly.

I sent this issue to TE, they exchanged my OP-Z with a brandnew OP-Z as we couldn’t locate the error in a longer email exchange.

When I connected the new OP-Z to my two computers, CONTENT mode worked ONE time! (It took quite a while before the OP-Z drive showed up though).

HOWEVER, after CONTENT mode worked ONE time with those two computers, it stopped working every time I tried it again.

TE knows about this problem and I am actually happy I am not the only one here. Hope they solve it in a future update because it is really annoying going through a computer to save your work that isn’t even yours.

Having said all that, UPDATE mode ALWAYS works!

I don’t have this problem, but have you guys tried using the firmware update 1.2.31 that TE posted yesterday? https://teenage.engineering/_software/op-z/z_firmware_1_2_31.zfw