Korg nano kontrol and op-z

would those two work together, like controlling (kontrolling?) the mixer and mutes? how would I set this up?

As long as you can map MIDI cc from the nanokontrol to the OP-Z you’ll be able to control mutes and mute groups.The guide gives you the details of the MIDI mappings: https://www.teenageengineering.com/guides/op-z/midi. I haven’t used the nanokontrol though I’m thinking it ought to work ok with OP-Z. Just connect a USB cable from your nanokontrol to the unit.

Has anyone had any luck using the Korg Nanokontrol or Nanokey Studio with the OP-Z?

I’ve used it with nanokey studio.
Conmected with usb c to micro cabel.

@awb79 said:
Has anyone had any luck using the Korg Nanokontrol or Nanokey Studio with the OP-Z?

I couldn’t get my nano’s working when I tried them but it was on the last OS not the current one, I tried the nanokey2, nanokontrol2 and nanopad2 with a c to micro cable.

Nanokey2 works fine for me with a normal cable

I noticed that pitchbend was being received but not notes, so I did a factory reset and tried it again and it works as expected, then I restored my projects and it went back to not working again, so then I did another factory reset and this time copied the midi config file into my backup, replacing the one that did not work, restored with the replacement midi config and now it all works properly.

So if anyone is having problems with midi not working correctly, it is worth making a backup, and doing the above.

Many thanks, i’ll give that a go!

I wasn’t getting anything on my NanoKey Studio, not even a light, updated to the newest firmware (1.1.17, up from the one before last) and it seems to be working pretty well now. Note that I also flipped the USB C over, so who knows.
Nice to be able to arpeggiate more than just the arp track. The slightly velocity sensitive keys and drum pads are going to come in handy, too.

Nanokontrol via usb works perfectly too.

Hey there, any other steps you use to get your OP-Z to work with the Nanokey Studio?

I bought a direct cable from USB C to Micro USB. Link below.


However, when I power on the OP-Z then plug the cables in, then turn the USB mode for the Korg on, 4 of the 8 pads light up for a moment. Then the Korg goes dead.

I’m on the latest firmware for the OP-Z and the Korg has not been modified at all since purchase at the middle of last year.

maybe the nano studio takes too much current than the Z can provide?

@docshermsticks said:
maybe the nano studio takes too much current than the Z can provide?

That’s exactly what I was thinking, but I keep seeing folks confirming that they were able to do a direct plug, like jesiah right above. You think the OP-Z/Korg is faulty? Both are new, and updated to latest firmware…

Such is the way it seems when it comes to USB-C cables today. In my and many others experience, some work and some (if not most) do not. Not sure if these cables contain small micro IC’s (such as Apple lightning cables), but there is something that is not “class compliant” about many USB-C cables produced out there. Would be great if someone out there started a database tracking working cables for MIDI music.

If the nanokontrol2 uses a USB micro connection, I’ve found this cable works well:


Yeah, I have been using Cable Creation cables with good luck. Also possible thing: the cable out of the OP-Z is an OTG (C to female USB), which I then plug in a standard USB to micro they goes into the nanokey. Both of these are Cable Creation, both together are only about 1 foot long. Besides updating the firmware, not sure what else I’m doing differently.
Perhaps try resetting the Korg to factory settings?

Also of note, that USB C OTG cable is the same one needed to plug a USB to MIDI cable into, which has successfully run my Volcas. Haven’t figured out how to go about getting all those devices working the same time together.

Hi…i use but can’t set midi channel from the device itself, have to connect to a computer to program the scenes. The knobs limit sending CC data in steps of 2 (0,2,4,8 etc). So you only get 64 steps instead of 128.

pcb assembly services

Better late than never. My original nanoKey Studio was stolen and a year+ later I finally got a new one, and it wasn’t working quite as easy. But here’s a process I figured out that seems to work:

Troubleshooting tip for Korg nanoKey Studio w/ OP-Z:

Problem: nanoKey boots briefly when plugged into OP-Z USB, top 4 pads flash white, then all lights go off, & unresponsive.

Culprit: not enough power for bootup, probably

Setup: OP-Z will need USB-C OTG cable (female host), then standard USB to micro USB cable into the nanoKey (don’t plug in yet)


  1. Turn on OP-Z.

  2. Turn on nanoKey on battery first, blue light flashes

  3. Plug in cables

  4. Then quickly slide switch over to USB power. nanoKey Studio will power cycle in the normal way and should now work.

Also, try making the settings in KorgKontrol application for USB all to lowest power possible

Also try: a powered USB hub will provide enough power for the Korg, but not using it is slicker & portable.

Also, I am using Cable Creation brand, fwiw.

I had a nanoKey Studio a couple years ago and it used to work a lot more seamlessly. Then it got stolen and I just now got a new one… had to try just about every cable and order of operations, and this is the only one that worked… but now it works great! Yeay portable velocity sensitivity and true triplets.

you know it has bluetooth midi ?