M-Audio keystation mk3 not working on oplab MIDI in

Hey all,

I recently got the oplab module for my op-z, and I was trying to hook my M-Audio Keystation 61 mk3 to the op-z using the MIDI in port on the oplab module. It does not work at all.

I can connect the keystation to op-z via USB, and that works as intended, but still no dice on the standard MIDI connection through the oplab.

I tried a factory reset of the op-z (also did a factory reset of my keystation) and re-updated the op-z firmware. That still did not fix it.

Has anybody had a similar issue? or had success using M-Audio controllers that may have some insight for me?

Unfortunately I do not have a quick way of testing the 5-pin MIDI out on the keystation to make sure its working properly, unless I take it into the store.

did you put the switch to midi instead of trig?
on the module itself :sweat_smile:

Hey Johnny, yes I have it set to MIDI, not Trig :smile:

Also, I didn’t clarify in original post that I have flipped through all the MIDI settings on track 14 (module track) to, e.g. make sure MIDI in is enabled, play around with channel 1 to active, etc. and still no luck.

I am going to head in to the store when I get a chance to see if I can get the op-z talking with some other midi devices, will post back when I have some updates.

This sounds stupid but you have it going into the input right? It’s easy to forget which is which with the cover on.

Hey Kja, I was totally tripped up by that the first time I put the cover back on. I have since left the cover off while I troubleshoot, so it is indeed going into the MIDI in :smiley:.

And is being sent on a synth channel? Are you sure that channel isn’t muted on the module track on the opz? Are you sure the controller isn’t muted on that channel or have local on or something? Have you tried taking the module out and print it back in? Make sure the locking tab on the module is locked in?

Hey, so I got it to work! Thank you Kja and JohnnyEgo for responding.

My problem was that the MIDI Out setting on the keystation mk3 was not properly set. As it turns out, the manual for the keystation is not entirely clear on how to change the MIDI out setting. For anyone that may encounter this problem in future, the solution is to (on the keystation):

  1. Press Advanced
  2. Press the MIDI Out key, until the octave lights are green
  3. Press the Enter key

Now its time to jam.