MIDI clock from Ableton Live to op-z not working

I’m having an issue getting midi clock working from Live to the OP-Z.

My OP-Z settings:

My live settings:

This is the result:

Firstly, the OP-Z doesn’t start when I click “play” on Live, for the first time. I have to click it again for the OP-Z to start. Then the OP-Z starts, but it’s not in sync, and seems to stutter on some steps.

I’ve also tried the “pattern” in the Ableton live MIDI Clock Type, and that presents the same issues, except that it when pressing “play” in Live, the OP-Z doesn’t start at all.

Any advice would be greatly appreciated.

My next try is going to be resetting the OP-z completely with the new firmware and seeing if that helps.

[EDIT] - just did a factory reset and that didn’t help. Downgraded to a previous firmware and that didn’t help either.

I’ve also tried to sync the OP-Z to my iPad running Cubasis 3 and it works fine, although with a slight lag.

Don’t have an answer yet, but I ran into a similar problem with the Digitakt this morning and hope to troubleshoot this afternoon. So I’ll let you know if I figure anything out!

Try enabling Track in Ableton and sending a MIDI note through the External Instrument device. For whatever reason, that seemed to “wake up” the OP-Z when I did it with the Digitakt.

Thanks for the suggestion. It unfortunately doesn’t help. The issue isn’t so much with Ableton starting the OP-Z, but rather that the sync is completely wonky.

See if you want to have Ableton as the master clock, try disabling midi clock out (option 5) and midi echo (option 7). Only enable midi clock in (option 4).