More syncing problems with OP-1 to OPZ

Here’s my tale of Woe:

I’ve been working on a Track using my OP-1 and my OPZ, and up until tonight I haven’t had any issues. Now suddenly things have gone haywire.

What seems to happen is that it connects and then immediately disconnects. I plug it in, the little green light on step 16 flashes if I quickly hit “play” on the OP-1 it will start the OPZ… aaaand then step 16 will flash red and it will either freeze up, or keep playing regardless of whether I hit start/stop.

I tried a factory reset (losing my drum track, but whatever I guess) I’ve tried connecting to the app and tweaking every combination of midi settings and it doesn’t seem to change anything.

I’ve also tried turning off and on USB charging for both devices, and that hasn’t done it either.

I’m wondering if something got screwed powering on the unit? I forget exactly what my order of operations was, but I think i had the OP-1 and plugged into the OPZ when I turned on the OPZ and it didn’t like that?

Edit: I also tried reinstalling the Firmware update to the latest firmware and no luck. I’ve also tested the OP-1 with Ableton using it’s MIDI over USB and I have full control over everything, so I don’t think this is an OP-1 problem.

I am noticing that if I have Midi in/out and Clock in/out all enabled, the OP-1 will switch from from whatever BPM it’s set at to 220 bpm.

Also When it first connects and i have control, the OPZ does switch it’s BPM to whatever I have the OP-1 set to… so it appears that, at least at first, things seem to connect normally, something is just causing it to disconnect or turn off.

Anyone have any suggestions for how I can fix this?