New firmware for PO KO II 1.2.3

  • double-trigger during quantized live recording.
  • loop could exit to the wrong position when exiting and entering loop quickly.
  • prioritize held notes over released notes when running out of voices.
  • velocity and duration note changes (done with SHIFT + POT) could get lost.
  • EP SAMPLE TOOL could not restore max length sounds.

Still waiting for it to show up in the update utility


Update available now, but it fails with “an error occurred when installing firmware” (1.2.2 → 1.2.3). Display changes to “RDY” when starting the update.
I tried all kind of workarounds, about 10 attempts failed (3 different USB cables, reboot PC, reboot EP-133 and also factory reset EP-133, etc.)
Did it work for anyone?

Edited#1: It worked finally!
My setup: Chrome and Edge (Windows10).
What solved my problem is not entirely clear:
Maybe temporary server problems on TE side.
I recognized that display changed from RDY to TRF during two attempts, but progress stopped at 2%.
In parallel I updated to latest Chrome version and
re-enabled Windows Runtime MIDI API (Chrome system setting). Suddenly firmware process executed without issues.

Edited#2: I am able to reproduce the issue in Chrome now.
Following default setting for MIDI-API does not work, it must be changed to ‘Enabled’.
(strange because backup/restore with sample editor works with both settings)


hmm that’s pretty odd… I did it today and it worked without issue. I’m surprised even after a factory reset that it didn’t work.

Ok, thank you. This answer motivates me to continue my attempts e.g. different PC …

What browser did you use? Maybe try a different one and make sure it is up to date? I’m using the latest version of Chrome

It worked now!
My setup: Chrome and Edge (Windows10).
What solved my problem: Reset of Windows Runtime MIDI API (system settings).

1 Like