New OP-Z doesn't turn on/work when not connected to a power source.

I just got my OP-Z from Ebay (Description was open box, and seller insists it was never used. 99.8% positive rating so I believed them).
Anywho, I tried turning it on and I had no success. I assumed it was out of battery, so I plugged it in.
Once it was plugged in, it turned on an worked fine. I checked the charge level and it was full, so I unplugged it again. Automatically, it turned everything off. I plugged it in again, and it worked again.
I tried taking the battery out and putting it back in, and it still did not work. There’s a little ding on the battery, but it seems to be surface-level so I haven’t really thought much about it.

Does anyone have any idea what might be happening? How should I proceed?? I was excited by the portability of the OP-Z but now that’s sorta been thrown out of the window. Anyways, any suggestions would be greatly appreciated.
Thanks in advance!!

Send it back!! Something is wrong with your battery…

Agreed, it’s not working as intended, send it back.