On a full track, problem with notes getting choked?

Hey y’all, I’ve noticed that sometimes when I have a project going on all cylinders (i.e. all tracks have something playing), some notes with a long sustain on the lead or chord track get choked (giggity) way too soon, sometimes only a step or two after it gets played. If I mute a few tracks in the mixer (drum or synth tracks), the problem goes away, but if I just reduce the track volume to 0, the problem is still there. There isn’t another note being played after on that track, so it’s definitely not a problem of track polyphony.

Does anyone else have this problem? I’ve run into it on almost all my projects, and it’s really starting to bum me out. I’m thinking the OP-Z is hitting a limit on processor load and automatically choking notes to avoid glitching?

It seems to be more prevalent when I’m using the new organ engine. I haven’t noticed it more often with the new reverb engine.

Have you tried setting the „generous chords“ option in the general.json file to „true“?
It might at least help on chord track, since it allows for 6 note poly on chord track (stays 4 per step but helps with long envelopes etc).

Apart from that: I also recognised that problem.

Yes but I have found that it’s more of a loudness problem and there is too much going on at that specific time. Try turning down other track as well and just back everything down, compressor Etc. That usually fixes the cutting off for me.

best way would be do make a video with the issue and some explanation on how to recreate it.

i would be interested to see this here but it’s a good time now to send it to the TE support and they‘ll help out with a bugfix etc.

Yeah, I’ve tried it with both values for generous chords. Unfortunately, that doesn’t help; this seems to be a separate issue from track polyphony. At least I’m not the only experiencing this!

Thanks for the suggestion. The problem still persists when all other track volumes are turned down to zero, but not when the tracks are disabled in the mixer. That’s what makes me think it’s a computational limit. I have turned up the compressor a little too much and had the overzealous ducking on other tracks, but that doesn’t seem to be the problem here.

Here’s a video with the issue. I start by playing the pattern where I’m having this problem. You can’t hear it too well over the phone mic, but the chord track is cutting out.

At 0:14, I switch to a version of this pattern with everything the same, but all tracks have their volumes set to 0 except for the chord track. I also changed the chord track to a patch that makes the issue a little more obvious. The notes that get cut out are consistent when the pattern is repeated, but they’re not the oldest notes. Sometimes the most recent note gets cut, which is definitely not ideal. If the oldest notes got cut, I might have been able to live with it, but that’s not the case.

At 0:38, I disable some of the synth tracks in the mixer, and the problem goes away. That’s what makes me think it’s a computational limit.

Thanks for the suggestion, I’ll send this video to TE with a description of the problem.



I also have this happen sometimes…I have a feeling it happens more often when using the string synth engine.