OP-1 fastly losing charge while turned off and high pitched noise while charging

Dear Community,

my problem started a while after the update to 246. The machine lost a lot of battery even when switched off and then at some point did not turn on at all (high pitched noise from the speaker no matter in which position the on/off switch was). Therefore, I thought that the DSP board is defective. I also had a spare connecter-board and tried that - but that didn’t solve the problem.

After I unplugged the battery and plugged it back in - at least it started up again.

It still makes that high pitched noise when charging - depending on cable and power supply in different frequency. Now I’m not quite sure if it’s just the battery failing, the DSP or something else. I rolled back to 245 but the battery drainage is still present (battery all gone after 1 1/2 days turned off).

I you have any experience with that as of which component could be failing, it would help me a lot since I can tackle the issue more precise. I tried factory reset, firmware rollback, different cables, chargers etc…

if your battery isn’t holding a charge anymore
the most likely reason is that your battery is failing

the battery is relatively easy to replace compared to maybe some of hte other components
so might be a good thing to try atleast

worse case if your problem still persists then u know its something else causing your issues

1 Like

Hey there,
thanks - I ordered a third party one and will report once it’s replaced. My greatest fear is that there is something wrong with the DSP that draining power even when turned off :confused:
Does anybody know the battery connecter type used on the OP1? I think it’s a 2 pin SH 1,25mm Micro JST?

these are the connectors they use
(click thru for the links)

tbh u are prolly better off using the connector on your existing battery

1 Like

Alright - thanks a lot!
Replaced the battery but it’s still losing charge when turned off. Like the charge is all gone after 2 days being turned off. So connector-board and battery weren’t the problems. My guess now is that the DSP is faulty. Is there someone on this forum who has experience with the circuit of the board to make a guess which part of the DSP could be damaged? I want to avoid buying a new DSP Board for a lot of money when all that needs to be done is replace a capacitor or a resistor…

I’m having the same issue :confused: Got my OP1 in early 2017, so its managed 6 years of useful and creative life, but seems its sadly heading towards retirement and obsolesence

1 Like

Hey there!
I’m not willing not give up yet :face_holding_back_tears:
The wonderful @jon helped me so I could replace one of the capacitators but that didn’t solve it. I found a similar problem with the battery draining while turned off on a ZOOM device and their problem was a bad cap. So yeah - Jon also suggested that it could be a damaged flex cable and I’ve ordered one but it hasn’t arrived yet. What bums me out is that it’s impossible to obtain my specific dsp (white - REV 2) from the the repair shop here in europe.
But good luck on your journey - maybe you can find a solution!

1 Like

how old is your OP-1?

is the OLED display matte or glossy?

can you post more pictures of the interior?


Do you need something specifically?

Replaced the ConnectorBoard - the Cap (as obvious) and the battery. I bought it used - so can’t really tell how old it is. But it worked for at least half a year

From the pictures the display looks matte but I’m not sure if it does due to the picture being out of focus on that area, please can you confirm it’s a matte screen?

I’m asking because from my research there are several revisions (at least 4) each with it’s own OLED display and connector to the DSP board, as far as I know there is only one revision with a matte display (which should be the latest).

As for the high pitched whine, if it’s happening while charging, that’s normal, it’s a feature to prevent pushing too much current on a drained battery which could very likely reduce its lifespan.

Basically if you have a drained battery the first hour of charging (more or less) should happen very slowly, then the high pitched whine should stop and the battery should start charge more rapidly.

I assume that you have already tried to reset the battery indicator an let your OP-1 charge for 3-4 hours.

Also I see that you’ve replaced the battery, I’ve heard stories of people frying the DSP board by cutting both wires on the connected battery and causing a short, battery should always be disconnected first and then the wires cut one at a time. (can you confirm this didn’t happen to you?).

Is your replacement battery an aftermarket battery?
Have you double checked the correct polarity of the battery?
(very often those aftermarked batteries have polarity inverted)

Have you reused the old battery connector? In any case triple check the connector pins with a magnifying glass to see if there’s anything wrong there.


Thanks for responding. So - the battery wasn’t attached when I replaced the connector. And I didn’t cut the both wires at once. One after the other. So that didn’t fried the board.
The machine operates exactly the same after replacing the battery.

Yeah - I used the old connector and wired up the red to the red cable and the black to the black cable.
It’s not the original battery from te, but the specs are almost the same (except physical size).

I think if the polarity would be wrong, it wouldn’t operate as it does (normally except for the massive battery drain). But I’ll check it again tonight. I’ll take a close look at the connector pins too! Thanks for the suggestions

What I meant is that those aftermarket batteries sometimes have inverted colors on the wires, it is always best to check the polarity before installing those batteries (it is also stated in most of this batteries description/manual).

Please don’t forget to check the polarity of the battery before looking at the pins.
You could very likely be charging and running your new battery in reverse, in which case I’ll recommend to dispose that battery which is now ruined and replace it with a brand new one (after assuring the right polarity).

Maybe this isn’t the cause of the issue but it’s worth checking before proceeding with further investigation.