OP-1 manager app for iOS

Jeez, you could of censored something off of that screenshot. Horrific. Gonna give me nightmares.

1 Like

The Files app is the official Apple one from the App Store.

i’ve try with my ipad 2019 ans iphone SE 2020

Ok so i have that Files app. It shows a ton of locations to save files, etc., but it does not ‘see’ the OP-1. So, I presume the OP-1 Manager won’t see it either.

Is there some setting on the iPhone that lets it use other objects as external drives?

BTW, here is how I’ve got it hooked up:

  • I attach the iPhone X to the camera kit.
  • Plug in the TE cable USB end into the camera kit
  • Plug the TE cable USB-B mini to the OP-1

this may sound stupid but u guys are putting the OP1 into DISK mode right?

I think you need the camera connection kit with charging port for the iPhone. I have apple’s without, it doesn’t work on my iPhone when i connect OP-1 but works on my iPad Pro. Same issue when connecting OP-Z to the iPhone, at least foir me. So it might have to do with power consumtion.

Yes, i put the op-1 in Disk mode

It possibly only works with the newer iPad Pro models? I can not see the OP-1 on my iPad-Air2, but the op-z works via USB with the OPZ-app. So it should not be a problem with the USB-Connection.

I bought an official CCK with power for my lightening phone and 1st gen ipad pro but even this plugged in dosn’t give it enough power. If you are using an iphone/pad with a lightening connector you need to use a USB hub to generate enough power. There is a video here that might help: https://www.youtube.com/watch?v=zW-yOzVQXrc


OP-1 probably draws more juice than OP-Z over USB.

Thanks! I can confirm this now, just tried connecting my usb hub to my iPhone and my OP-1 to the hub. It works!! :partying_face: :grin:


Yes I can confirm as well, I used a very old USB 2 hub with no power, and amazingly it worked.

1 Like

Anyway to backup to anything besides icloud?

You see and that was the problem for me I couldn’t get it to work at all, and everything it claimed it could do I can just do by plugging the op1 into my PC… WITHOUT any sort of extra single or powered usb hub BS. Just no real reason to even have the software imo

To be fair, that’s an iOS problem that has nothing to do with this app.

To be honest I didn’t get much joy out of the app but pleased to figured out how to copy tracks over and rename patches via my phone using the USB hub it will be very useful when I’m away next month.

Yes… then WHY release an iOS app then if it has “this problem”.

You should probably just not buy an iOS device.

Because some people like to try to do as much as possible with iOS despite the limitations apple puts on the device, platform, developers and users. “this problem” is probably one of the many reasons TE never made a iOS app to work with the OP-1.

Another reason would be that traveling with an ios device, whatever bs hubs and dongles are needed, and an op-1 is lighter and smaller than traveling with a laptop and op-1. Some people like to leave the laptop behind.

1 Like

I mounted the OP-1 as an external disc and explored the ‘synth’ folder via the commandline on macOS. The folder has .aiff files that say “OP-1 Patch” when played with any audio program. I ran the ‘strings’ command on a .aiff file, and noticed something very interesting:

There are patch parameters within the .aiff file!!

sowt)Signed integer (little-endian) linear PCMAPPL
"fx_active":false,"fx_params":  [2952,320,5247,17407,0,0,0,0],
"lfo_params" [9280,32606,1296,9200,0,0,0,0],
"lfo_type":"value","name":"20161208_0420","octave":0,"synth_version":2 ,"type":"dsynth"}