OP-1 not working as a control surface with Ableton 11

Hey all,

Got my OP-1 about a week ago and I can’t keep my hands off it. I had heard about how it integrates with Ableton and thought I’d give that a shot today. I installed the control surface script in Ableton (using the one from TE’s manual), put OP into CTRL mode, and it all worked… for about a minute. I was able to play/stop and adjust parameters, but after a few button presses it stopped working.
At this point I’m able to use the keyboard to play midi notes in and that’s it. All the other buttons on the OP are definitely sending signal out, but they don’t want to do anything.

I have tried:

  • uninstalling/reinstalling the script a number of times

  • all of the control surface scripts I was able to find

  • different combinations of track/sync/remote in Ableton

  • uninstalling/reinstalling Ableton

Any suggestions? There aren’t many threads online that address my issue, hopefully nothing’s broken.

Thanks!

Unfortunately I have no help to offer, but interested to hear if you work it out. Sorry I’ve not tried the OP-1 to control ableton, but have both <3 Good luck.

Ableton 11 seems to rely on Python3 for control scripts compared to Python2 for previous versions of Ableton. You may try out the Python3 version available at GitHub - marctdt/op-1-ableton-live-control-surface: Ableton Live Control Surface for Teenage Engineering OP-1

1 Like

Unfortunately I’ve already tried that script, installed both in the Ableton user library (in Documents) as well as the installation directory (same folder as Ableton’s .exe). I’ve verified that I have Python 3 installed, as well as the existence of another Py3 installation within Ableton’s resources folder, so I know I have the prerequisites.

I’ve been scratching my head about this for days, hopefully there’s a solution short of reinstalling Windows.

You may find below the location of my remote script which is working fine as Control Surface in Ableton 11 - (it is the same as Ableton’s .exe). It seems that none of the script folder names contain spaces so that could be another thing to check.

C:\ProgramData\Ableton\Live 11 Standard\Resources\MIDI Remote Scripts\OP1