OP-1 Screen has gone blank

My OP-1 (Very new, less than 2mo old) was working fine yesterday. I powered it up today, and absolutely nothing happened.

Curious, I plonked a few of the keys. It made noise, but still no visuals on the screen.

I tried restarting it, several times, I tried booting while holding the COM key, I even tried to reinstall the firmware with no screen to guide me, but none of these things worked.

Any ideas how I could fix this? Is my OP-1 just defective? should I seek a refund/replacement?


I have bought my OP-1 just today, came back home, let it charge until it was full, booted it up and I have the save issue you have.

I have sound if I press the keys but my screen is definitely not booted.

I already contacted TE on twitter and the store were I bought the OP but won’t get a reply before Monday.

Seems like most people had to return the product to be replaced or repaired

I was so excited to play with it on day one but this issue is killing me :frowning:

Hi everyone, just following up on my situation.

I went back to the store with my defective OP-1 and they exchanged it with another one, which I directly tried, and is working! Yay!!