Op-1 stop and play buttons not working

Hey folks, wondering if anyone has encountered this
Op-1 stop and play buttons stopped working out of nowhere, Did the keyboard test and when you press one of the stop or play keys they both register in yellow but do not go green.
Updated to the latest firmware and no luck. Formatted the drive too. The issue doesnt seem to be mechanical because when you hold shift and hit play the tape will play backwards but hitting play will cause it to pause again. Its really unusual as it was working perfectly last night but when I switched it on this morning its not working at all

any help would be greatly appreciated

1 Like

Hey, looks like you may need a new keyboard, my seq and another key did the exact same thing. Hop over to iFixit, read the guidance, order a keyboard and swap it out.

Im fairly positive its not a hardware issue as it worked again but then stopped again. The fact it works when you hold shift would show that the keyboard is receiving input The keyboard test registers the keystrokes too, Its a weird one, I’d be bummed if I went through the effort of buying and installing a new keybed and it not resolve the issue

u could try cleaning the button contacts
or even reseating the ribbon cable that connects the keyboard to the main board
maybe its a funky connection?

also have u tried a factory reset?
it is different than updating the firmware or formatting the drive
and usually solves weird issues that creep up over time.

What you’re describing is what happened to me, buttons appeared to intermittently work, but when I did the key test they showed an error then ultimately died. Sorry to be negative. It might be a good idea to try the idea suggested of reseating the ribbons first.

Cheers Steve, I just wanted to really exhaust all other possibilities haha, I might just have to bite the bullet and get a keyboard if the reseat doesnt help

1 Like

Let me know how you get on, hopefully reseating will fix it :+1:t2: