OP-1 Won't Mount as Disk After OS Update

Hello all,

Just got a 2nd hand OP-1 this month. It was running r. 235 so i thought i should update to the latest OS and get the audio streaming features + bug fixes etc.

Anyway, all went well, but later on when i wanted to back up my work the OP no longer shows up as a disk on the same computer that i used to do the update (Macbook Pro 2012, osx 10.12.6). I can see it in the system information under USB devices, there’s an entry called OP-1 Disk, but nothing mounts to the file system.

Now, i know it’s not the USB cable, as the audio interface feature works fine, and also MIDI is fine when in standard mode. And i connected the unit to my old PC laptop (running Win XP!) and it shows up as a disk there just fine, i can view files and move things about. So my thoughts are that somewhere along the line there has been a bug introduced which means my older computer really doesn’t get on with the way the filesystem is implemented on the OP with later OS.

Has anybody encountered anything like this before? It’s extremely annoying tbh and has massively soured my experience with the device.

Also is there anywhere to get r. 235 from? I tried the wayback machine but they hadn’t cached the OS file.


maybe try a factory reset on your OP1. sometimes that fixes weird glitches that occur.

1 Like

Yeah, i did that and that’s what got me in trouble. Because it asks you to connect the computer and load a firmware. My OP was basically a brick for an hour or so until i remembered i had the old PC in the cupboard. Lucky it worked eh!

Ok, thanks for the OS archive link above. I’ve gone back to r. 235 and it still doesn’t mount on my Macbook, not even in te-boot mode. So who the hell knows what’s going on but it’s probably to do with the computer seeing as it still works fine on my old PC. Going to have to sell this little beasty if i can’t work it out as i’m getting very pissed off at how much time i’ve wasted on this and stress it’s causing. Basically unusable if i can’t backup stuff off it… :-/

factory reset doesn’t need to reinstall the firmware
u must be referring to reformat the drive option maybe?

i’m not really sure maybe try rebooting your macbook? maybe its just a glitch on that end?
if u can see hte drive on your MB, can u try to mount it manually?
maybe in disk utility or via terminal?

i have an old macbook pro too (late 2008, running 10.11.6) and it connects just fine

1 Like

I got the disk up.

What i did was the reformat option and then installed r. 235 and after being connected for about 30 seconds in disk mode the folder appeared. When i did the r. 243 install i had left it for much longer, and nothing was showing up after minutes, so no idea what was wrong, but i’m going to just stick here and hope it works fine from now on.

Thanks for the help peeps.

te-boot still doesn’t mount a drive for some inexplicable reason when i choose firmware upgrade option. This piece of shit is driving me mad. Will be selling it ASAP and going back to using professional equipment like i’m used to. With proper manufacturer support and decent programmers/engineers.

The name of this company is quite apt really, their abilites are very teenage and could do with a few more years in school.

Ok, so after browsing the OS archive i realised the bootloader on my unit is still the one that got installed by the r. 243 update, v.2.29, which is probably why that part has the problem mounting a disk on my computer but the main firmware r. 235 works. Somewhere in between 235 and 243 they must have changed something about the way the device presents the filesystem to the computer for mounting, and my Macbook doesn’t like it, could have been an update to yaffs2 library or something, who knows. I will call this a definite bug though, and a pretty major one too.

If anyone in London UK wants to buy an OP-1 after new year, hit me up.

well, the teenagers replied to my extremely detailed and obvious software bug report e-mail with a suggestion that i send the unit to germany to be fixed at my expense even though it’s not broken and is just encountering an issue they introduced with a firmware update.

fucking useless bunch of amateurs. worse than amateurs actually, as they seem to think they are on the level of apple or some megacorp with their extraordinary aloofness and ignorance towards their customers.

Right, due to my annoying habit of needing to find answers at the risk of breaking my toys i stuck at it and was wondering if i could figure out the last ‘working’ firmware before r243, and lucky me first one i tried, r242, seems to mount and work fine on my Macbook now. I don’t know what i was doing wrong when i tried it before, but probably just not waiting long enough for the disk to show up out of impatience to try and get things working.

Interestingly the bootloader also got reverted (to v2.27) when i installed this version, which apparently hadn’t happened when i rolled back to r235 (was stuck at v2.29), so now i get full access in both disk modes.

I’m going to say this bug has been introduced in r243, probably due to the addition of extra complexity of the audio streaming. Hopefully they can work it out cos the audio streaming is useful. But that will be for whoever receives my unit cos i’m still selling it.

1 Like

Just to say that the same thing is happening to me. I sent TE an email about it. I really don’t think it’s software. Unlike you, however, I couldn’t get it to connect even when rolling back the boot loader, firmware etc.

It connects immediately once the disk has been formatted.