OP-Z cutting out with USB recording


I have been having issues with my OP-Z and recording through the USB. I have my OP-Z connected from usb c to usb c into my iPad Pro. I am using an official iPhone usb c cable that came with my iPad.

When I am recording into GarageBand I can set up monitoring on the iPad and when I press play everything is picked up and and heard through the OP-Z but, when recording, after the first measure the monitoring on the OP-Z will cut out but GarageBand continues to pick up the OP-Z output and record it. The OP-Z will then refuse to monitor the usb input afterwards. It takes a full restart of the OP-Z to be able to set up the usb monitoring again.

When listening back to what has been recorded the recording is filled with moments of scratchy static. And right after the first measure, what would normally be the second pattern playing on my OP-Z, the song starts over again from the beginning.

Has anyone else had any problems with usb recording from the OP-Z?

I have made sure that the OP-Z is not receiving a charge to make sure there would be no static when recording. I’ve tried a factory reset. I don’t know what to do at this point. Any tips or advice would be greatly appreciated. Thank you in advance for your help.

It has something to do with your buffer size setting. I guess the OP-Z’s cpu is not very strong when recording over USB. If you increase your buffer size in the audio settings of your DAW, that fixes it… However, doing so also massively increases latency. It’s been an issue forever and I hope they are able to patch it or something in the near future.

Thank you very much for your response! Hopefully I can figure out a way to adjust the buffer size and have it work.

1 Like

Keep us updated on your findings

So I figured out what was making it bug for me. My second pattern dropped completely one of the effects I had on my snare drum in the first pattern. For some reason that didn’t play nicely with GarageBand. I copied the effect settings over to the second pattern and it stopped cutting out while recording. No clue why that made a difference but it did. Still doesn’t give me great confidence in recording through USB though. But thanks again for you response