OP-Z Microphone not working

I turned my OP-Z on and the microphone seems not to work right. I can only hear a loud noise. Does someone experienced the same.
All the best.

Sorry if this comes across as patronising, but have you tried changing the gain? You use the Project and Fader buttons to change the volume, if you’re holding the device on its side. You can read more here: OP-Z guide: microphone - teenage engineering

Hi @cmkc thanks for the tipp. I am a op-z user since its first release. Changing the gain was my first guess.
The noise only gets louder when changing the gain. The funny thing is, when I release the screen button, the microphone works for a brief second. Very strange.
I even tried a factory reset. Didnt changed a thing.

Very weird, is it just the built in microphone that it happens with?

Hello! I am a Chinese user of op-z. I can only read English but not write English, so this is the text I translated using Google. Sorry!
I bought a second-hand op-z, and it turned out to be the same problem. I tried various methods, including resetting, or constantly changing the system version, but it didn’t work until I disassembled the machine and found an electronic link to the microphone. The problem was discovered after the component fell off the motherboard.
You can disassemble the machine, it’s very simple, use the method in this link https://www.youtube.com/watch?v=yIIZm0FF120 (please use a hexagonal T4 screwdriver)
Then look at the situations marked in my picture.
If it does not come off, check whether the electric shock of the connecting cable is normal and plug it in again.
If it falls off, you need to find a worker who knows how to solder electronic components to help you (but it may still fail).
I hope I can help you!
Good luck!