Op-z MIDI Thread

I’m wondering if there is any way to control synth presets via midi on OP-Z. For example, I have Animoog on iPad assigned to bass track on OP-Z playing patch A on pattern 1, then, when I’ll change to pattern 2 on OP-Z I want Animoog automatically change preset to B. These midi control options are obvious on Digitakt or MPC, but I can’t figure it out on OP-Z which feels more like a toy when it comes to external midi sequencing. Any help ?

Is 8 lit when you select shift on the module track? This should allow Program changes. Can’t remember if these are pattern or sequence specific.

Yes it is, but anyway, how, how to do it? I have Animoog or Model D being sequenced on bass track on channel 5. And now, where is bank or preset parameter change in op-z? This is totally unclear for me. Something what is so obvious on Digitakt or MPC Live here is total mystery for me.

From the site midi spec:

shift + 6
alt program change

shift + 8
alt_program_change
true / false

true: use bank 1–16 / program 1–16 to set active pattern.
false: pattern 1–160 is activated with bank 1 / program 1–128 and bank 2 / program 1–32

1 Like

Yep, I’ve seen this in manual. So I’m on bass track on OP-Z (MIDI channel 5), on iPad I have Zeeon synth set on MIDI channel 5. Sequence is playing, I’m pressing 1 on OP-Z and buttons below, but nothing happening. It’s like this on all other synths. On Digitakt for example, on MIDI track there is a settings tab, with knobs which are selecting bank number, preset number etc. I’ve seen cuckoo MIDI sequencing tutorial for OP-Z, I’ll try to look there. Without pattern change, patch select/change properly implemented on external MIDI sequencing, OP-Z is just a toy.

Start with midi channel 1 with Alt PC set to Y. As you change Sequences and patterns, the PC’s should be sent to the receiving device changing the preset based on the sequence/pattern number. This type of sync appears best to setup on a fresh Z, in order to build tracks around this quirk. I’d also play with CC modulation on pattern changes to mimic the effect of changing a patch to a whole new sound.

I’ve just updated my OP-Z and the midi now only sends notes through channel one. I can’t work out which settings have changed. Anyone help?

I would try a factory reset or choose another plug instrument, after updating and not factory resetting some plugs are not preselected.

midi wise I can tell that it works as expected sending out midi on ch 14,15,16 without any pre configuration

Finally hitting the midi limits with tracks 9-16 while syncing Nord Drum 3 as a drum/synth brain. Really hoping TE allows users to repurpose these tracks with app/file change. With the Mio 4 box, I’m now controlling 7 pieces of gear from the Z/OP-lab.

I’m now thinking of remote recording ideas for the Z. A foot switch that can separately activate record/play and delete would be a nice way to use drum controllers to record steps externally away from the Z.

Tried a reset and a reflash. Still only midi on channel one. Anyone else have this problem? OP-Z also crashes frequently when connected to OP-1.

I had this issue at some point as well, and I believe one of these two things that fixed it for me.
(apologies if these are obvious / things you already tried)

In your midi settings (either via the app, or the midi.json file when connected via usb in content mode),

  1. Is the first option, channel_one_to_active grayed out / set to false?

Mine was originally set to true, and at first I thought this would only apply to incoming midi, but it also might apply to outgoing midi. Either way I have mine set to false now with my working setup. (This setting can also be changed with the key combo shift + 1 while the Module track is active).

  1. Is each track set to its own midi channel (track 1 = midi channel 1, track 2 = midi channel 2, etc.)?

Again, you can set this via the app or the .json file. I would be surprised if they weren’t, but messing around with what midi channel each track was set to at least helped me debug things if I remember correctly (like setting the kick track to midi channel 15 and seeing if sending/receiving on channel 15 still controlled and/or output the kick messages).

ps. my midi I/O now works via usb and via the oplab module, in case you were wondering if one of those two might be the culprit.

pps. I think I found that setting things via the .json file was more stable than using the app or the key combos, so if you haven’t tried all 3 methods yet, you could also give that a shot.

1 Like

Does anyone have experience connecting multiple USB MIDI devices to the OP-Z over USB?

I currently have a Z and QuNexus keyboard, which work great together with a USB adapter. I’d like to add a knobby controller (thinking about a Launch Control), but I want to see if this configuration is supported before purchasing (sounds like I’ll need a powered hub in the very least). It looks like firmware 1.1.27 added support for this, but just wanted to check!

should be no problem with a powered hub

1 Like

Hello everybody !
I have a problem changing my opz midi-in channels.
I changed them in the android app but my opz is still playing on its default channels.
I also checked the json file and the changes are written there too.
I wanted my opz to respond from channel 5 to channel 12 and my kick is still on ch 1 and so on…
Do anyone have an idea on how to clear that issue?
thanks so much :slight_smile:

I’ve been happily using a usb-C to usb-B cable to send midi to The intellijel uMidi Eurorack module directly from my op-z. (badicaly without the oplab!) It stopped working after the last op-z firmware update in April 2020. I’m curious if it’s a known issue or it’s just a freaky coincidence that either my uMidi module or the cable is broken right after this update. Anyone?

Yep. I also have such issue. I’m using iRig Keys 25.

deleted…

Hi, I’m trying to solve a MIDI CC problem.

I recorded the punch-in track into Ableton along with the chord track for example. There are a few punch-in effects, like the loop effect, that influence the recorded midi steps in the sequencer. There are other effects like the sweep or duck, that are achieved by changes in the chord track parameters like resonance or volume. These changes are recorded in Ableton as well. In the clip envelopes.

And there starts the problem. The OPZ only sends and Ableton records only the Midi CC Data of the changes caused by the Punch In Effect and the MIDI CC Data that follows. But not the MIDI CC state before the Punch In Effect.

The MIDI CC Value before the punch-in data sets in is always 0.

Does someone knows this problem? Is this a OPZ problem or a Ableton problem?

I guess there’s a difference between “relative” and “absolute” midi messages.

is there a way to change those settings in Ableton?

It looks like this.


First the MIDI CC value for Resonance is 0. When the Punch In effect sets in. Ableton records MIDI CC values (relative) and after the punch in effect, the value goes back to it original value 46, wich should be also at the start. (like in the second picture.)

1 Like