Op-Z OS 1.2.20

it’s live and thx to TE its now possible to put in chords on a per step basis, from an external controller, while the sequencer is running without holding or activating record. thank you @tngjonas


  • fix content disk and midi port not appearing until removing / inserting usb cable (usb-a only)

  • fix flipped L / R signal in outgoing usb audio

  • fix bug that could cause a noisy microphone signal after switching effect plug

  • fix broken reset spark component setting

  • fix resetting spark counters on cued pattern switch instead of instant switch

  • fix bug with active drone notes preventing certain buttons from working

  • fix default arpeggio settings when switching to new pattern

  • improved step velocity editing

  • change track mute cc to treat value 127 as mute (in addition to 1)


Nice. Happy about the L/R fix. That caught me the other day when recording. I unplugged a lot of cables before I realized it was the OP-Z :slight_smile:

1 Like

v cool - also v happy about the usb over audio fix - for some reason I found that so idiotic and annoying.

Can this be done from the OP-Z as well? I’m curious why it isn’t mentioned on the list

of course! it was ever possible to do that internally but for me personally it’s one of the biggest things with this update.

especially because I’ve send a video directly to TE and they told me to fix it and now it’s fixed.


Midi clock issue still doesn’t fix :frowning:

Content Disk unfortunately still doesn’t show up on my Mac. :frowning:

best is to describe some kind of your setup and what scenario isn’t working at all, otherwise the best thing is to make a short video and send it over to TE and they’ll investigate if it’s clear what’s exactly happening

Interested in this one <3

Tell me more about this plz?

hold down a trig, insert a chord with a midi keyboard.

there was a previous bug which only stored the last played note instead of the whole chord. is now fixed


Legend. Thanks

1 Like

While keeping the trig pressed it’s not possible to use both hands to play the chord :thinking:

as long as the op-z stores 4 notes max on a trig it’s not so difficult at all.

otherwise- train your pinky :pray:

1 Like

Mind you own pinky :wink: haha
I was thinking about lower bass notes

1 Like

Nice! Good to hear that TE reacting to user bug reports :slight_smile:

Anyone noticing dropped steps on BD? I’m noticing BD on first step dropping out randomly occasionally on different patterns and different projects. It happens on patterns newly created or old patterns created prior to the update. Sometimes it loops around fine, but every now and then the first BD is missed, almost seems like a voice stealing issue.

It might be a coincidence but I was having a similar issue but with sending midi from the BD track instead. I was getting skipped notes and it wasn’t sending note data properly. I thought it was an issue with my oplab but switching the midi to track 8 seemed to fix my issue.

I wasn’t using any midi, just internal sounds, and no midi connected, but your post seems to indicate that this is a trigger issue rather than a voice issue, probably worth keeping an ear open to see if it returns on your midi setup too, I find it to be a pretty intermittent, which are always the worst kind of bugs to squish.

I have noticed it too. It happens randomly.

1 Like