OP-z Please insert disk drive

Just got an op-z, I attempted to put it into disk mode and it is giving me this mssg Please insert disk drive.
I have been able to update firmware on it so it seems weird that I cannot drop music files onto it. No one seems to have posted about this anywhere elce?

Hey, I’m sure you read the user guide, but I want make sure we are on the same page. With the supplied USB cable connected between your OPZ and computer, turn on the OPZ while holding down the Track button. The OPZ will then show up as a drive on your computer and you can access the samples. Is that how you’re doing it? And where does the message come up?

Enter ‘content mode’ before plugging in the USB.

Thanks for reply, yeah I have. And iv used the cable that came with the Op-z, and many outhers. The Op-z has been put into the correct content mode.

It seems like the computor wont recognise it as a usb device. And the mssge comes up when I click on the opz l.

That is odd. What OS are you running? I’m assuming you don’t have any issues with mounting any other USB drives on your computer, correct? If not, it might be a defective unit, possibly. You may need to contact TE for support. Or if its convenient, you might want to see if you can exchange it from the place you got it. Let us know how this develops.

I just purchased it from a ads site unfortunately.

and yes I was able to update the os to the most current one with 0 issues.

not good.

I have Windows 10 on my desktop and Windows 7 on my laptop - my Windows 7 Machine some times does not like when I switch between different modes with the OP-Z and will not recognize it. I found that if I have the OP-Z plugged in and go to Control Panel and then Device Manager and find the OP-Z USB Device if I right click it and hit update driver that usually does the trick. Give it a shot and see…

Make sure the OP-Z is NOT plugged into USB when enabling content mode. Only plug it in AFTER content mode is enabled.

CB

My Z crashes my Win7 pc everytime I connect it in regular mode, works great in content mode but when I disconnect and it reverts to regular, my pc gives bsod. sheesh. It may be the drivers, my studio pc is old and buggy…

1 Like

My OP - Z does not connect as a drive at all! My 2015 MacBook Pro does not see it as a drive. When I took it back to the store, we plugged it into their MBP and there it was, the OPZ drive! I can’t figure it out. Right now I can’t do a back up or upload sound plugs. It could be a problem with my mac - but other external disks work just fine. Suggestions??

Oh man I thought I was the only one with that problem. it was so odd.

1 Like

Is it possible that your Mac is configured not to display external drives on the desktop? If so, you should still see it show up in Finder.

Also, make sure that you put the OP-Z into content mode BEFORE making the USB connection to your Mac.

CB

Here’s a video we made about this topic. Hopefully it helps!

Man your vids are really good man!

1 Like

Thanks! I appreciate it.

Great tip, it works! Additionally, I found out that the drive option only works on USB 3 ports. In USB 2 you can use it for MIDI and audio, but it doesn’t show up as a drive, even with this workaround