OP-Z won't connect to iPad

This morning I ran into an issue where my OP-Z will no longer connect to my iPad. The app can see my OP-Z just fine. I press connect and it says “connecting…” but then says “not connected”. The light on the back of my OP-Z shows flashing blue, then green when I press to connect, then to red. Incidentally, I found using my iPhone works without issue. So I am wondering if there is an issue with my iPad

On my OP-Z, I have performed a factory reset and updated the firmware to the most recent version 1.2.14. On my iPad, I reinstalled the app, restarted it, and updated the software.

Does anyone have any suggestions?

1 Like

Maybe check if your op-z is connecting with other iOS device, and check if your iPad is connecting via BT with other gear.

1 Like

So, I eventual factory reset my iPad and that seemed to resolve my issue.

I’m sadly having this issue too:

To test, I tried a 2nd, brand new iPad. Same OS 13.3.1. I used iCloud restore to reinstall the OP-Z app on the new iPad. I tried connecting the OP-Z but had the exact same experience on the new iPad as on the old iPad: says “connecting” then does not connect.

OP-Z connects fine on my iPhone. iPads work with other regular bluetooth devices (speakers, pencil). I don’t have another BT LE MIDI hardware device to test other than the OP-Z.

I guess I can try:

  • factory reset OP-Z
  • factory reset iPad without iCloud restore

These options are rather severe. Is there another option to get this working again?

Someone had this before, you have to factory reset your ipad.