OP1 dead :(

I left my OP-1 connected to wall charger for a night, battery leds were blinking like usual during charging process. In the morning when I tried to switch it on it was dead. No led, no sound, nothing. When I plug charging cable nothing happens, not even single LED lights up I only hear silent high pitched sound in the middle of keyboard when charging cable is plugged (charging battery sound I guess).
It can not be connected to computer because its off.
I cleaned on/off switch with contact cleaner spray.
Tried to charge it again for 8 hours and wait 3 seconds after USB cable is disconnected and then turn it on but still it is dead.
Unit is about 3 years old.
Any ideas?

did you try to start it without any cable plugged into COM mode?

Yes I did but nothing happened.

is it still charging when connected to a computer?

does it make any sound when you hit the keys or select the synth or drums?

Yes I keep the charging cable in but there are no leds displayed indicating charging.
Only thing I can hear is a silent high pitched sound in the middle of keyboard when charging cable is plugged (charging battery sound I guess).
No sounds when I select synth or drums. It is basically dead :frowning:

I guess you’ve tried everything, I would contact TE support or open the OP-1 to see if the connectors are in place :100:

1 Like

Sorry to hear, I had numerous issues w/ my OP-1 not turning on/charging etc. Long story short, I went for the ifixit connector board, ended up keeping my original CB and just resetting it got me back to com mode.

TE support instructed me to upgrade firmware and it’s been golden since. Check out this vid if you decided to at least disconnect/re-connect the CB, should save you plenty of time.

Disconnected/reconnected connector board few times but it didn’t make any difference :frowning:

I remember the same, but after a few times of plugging and unplugging the USB cable it worked again.

Potentially you need a new connector board. They’re not too expensive (from iFixit) and you can probably re-sell if it doesn’t work…
Good luck!

Welcome to the club. :slightly_frowning_face:

My OP-1 was also about three years old and after charging it began to work strangely, I did a firmware reset, but could not install a new one - it stopped connecting to my computer. Changing 5 different cables many times did not help. This is where this story begins.

Unlike those who are willing to pay a service center for $500 with the replacement of half the device for one burned-out element of the board for $10, I asked a friend who knows electrical engineering to check my device. In my case, the DATA+ leg burned out directly on the processor. It is responsible for connecting to a computer. And usually, in high-quality equipment they are protected against high voltage using element at a cost of a maximum of $0.5, but OP-1 has not it.

SO WHEN YOU CONNECTING OP-1 TO A COMPUTER, YOU CONNECT ITS DATA+ AND DATA- THROUGH A CABLE DIRECTLY TO ITS PROCESSOR!

That is when you use MiniUSB cable, it is connected with 2 pins through the board to the battery controller and 2 pins for data (which are not used when charging, but they are nearby, probably are in your charging cable) could receive high voltage at any reason (e.g. static electricity) and burn out the processor.

I will describe my situation later when I solve my problem (we already changed Flash memory chip for $10 by a false idea and ordered a new processor for $15), but it does not cost hundreds of dollars for parts, except with the cost of working people with golden hands and the profit of service centers. And quite a lot of time for the delivery of already obsolete parts.

In your case, I’m not sure that replacing the connection board will help, it is better to take it to any service center for diagnostics to find out the reason.

I have ordered connector board last week from Germany.
I will install new part soon and come back with more information.

The USB DATA line is handled by the processor, it should have the necessary protection built-in. This is not necessarily a design issue as you try to imply.

Replacing the processor by yourself may never work because it may need to be flashed with the bootstrap code and encryption keys that only TE has access to.

It’s alive! ! !

After installing new connector board it started charging normal. After full charge device was upgraded with a new firmware from TE.
I would like to thank all users who took their time and helped me with problem.

@TommyB I am glad that your problem was solved so simply! :+1:

@punji If there is protection somewhere, why did the pin burn out? It is a fact. It doesn’t matter whether it’s a design error, a flaw or a mistake, for me it played a role and that’s why I’m upset.
I hope with OP-1 this might work, but it would absolutely not work with OP-Z. In OP-1, the firmware is unencrypted in the flash and the processor simply loads it during boot. In any case, I will write about the results of my experiment later.

Analog Device reference schematic shows the USB directly connected to the BF processor pins. There are some external protection diodes though, not sure if the OP-1 has those as well.

I hope you are successful in replacing the processor, but I’m very skeptical about that, since it would be a huge security flaw that would allow people to create OP-1 bootlegs (clones).

@punji I have not replaced yet, but I wait for it to be delivered (a few more weeks). I can keep it a secret if it can somehow affect TE. I am upset by some decisions in the design of their hardware and their support, but I am absolutely happy that they make such cool devices and inspire people around the world. I would like to help fix or do some things better than I can (for example, I think I make repairs more accessible for everyone by publishing information about my experience). And primarily repair my device.

Looking at the diagram, it’s great that you are exploring the matter so deeply. I am not very good at circuitry, but my friend said confidently that there is no protection and installed it for my device. I showed him this circuit and he said that there are no these diodes. This circuit is the reference design, as it should be according to the processor manufacturer, but does not mean that it will be so.

There is another controversial decision in the design of the board - it is always on. If you turn off the switch on the side panel of the device - it does not close the entire schema, the light on the DSP board continues to light and some kind of minimal boot logic will probably work. This in particular can explain why the device discharges to zero without being used (except for self-discharge of the battery) consuming some minimum current. It is estimated that it burns 3-5% of the battery per day in the pseudo-“off” state.