OP1 Midi clock slave drift


#1

I’m using latest OS with my OP1. I am using Logic X to midi clock sync the OP1 as slave, which syncs fine at the start but slowly the Tape loop drifts out over a period of time… my other hardware doesn’t do this when synced as slave from Logic (short loop say 4 bars)… is this a general problem with the OP1 when syncing it? It seems to be unusable as a slave with other hardware :frowning: If i don’t manage to fix this it might have to go


#2

This seems like quite a disappointing problem. Not been able to test, but it use to sync ok ,I think ,on old OS. Or maybe OP-1 was master ,can’t remember?have you tried driving logic with OP-1 as master?
Has anyone else had sync problems ?


#3

yep, we’ve discussed this before. findings so far suggest that:


- if you change the speed of (pitch-shift) the tape, sync will drift off gradually
- loop smoothing seems to introduce drift too
- if you monkey-sync without any signal whatsoever, curiously it seems to hold better
- if OP1 is master, it kind of sort of works OK


#4

As stated here: https://operator-1.com/index.php?p=/discussion/comment/41071/#Comment_41071


You should ideally set MIDI Clock Type from Ableton Live to Pattern instead of Song for a more stable sync. I don’t know if there is an equivalent in Logic

#5
As stated here: https://operator-1.com/index.php?p=/discussion/comment/41071/#Comment_41071

You should ideally set MIDI Clock Type from Ableton Live to Pattern instead of Song for a more stable sync. I don't know if there is an equivalent in Logic

Yep - there is. It’s in “File | Project Settings | Synchronisation | MIDI” and here’s what the options look like:


CB


Screen Shot 2017-01-25 at 22.49.46

#6

also the OP1 processes SPP incorrectly at most tempo values. (been trying to resolve this with TE but alas, no luck)


#7

Past few days have been a disaster trying to find workarounds with OP1, I’ve spent many hours - i’ve tried Logic and Ableton and with both there are issues with the clock timing of OP1… I’ve even tried program called MidiPipe to filter certain clock messages, or to send a song start message to give a little nudge… tried both Song and Pattern modes, Slave and Master… the sync is sloppy, it lags behind like an old fart


I recorded the OP1 audio out of a looped kick drum and you can see the delay and where it actually should have been! My other gear don’t have this lag when clocked (korg minilogue/jupiter), they sound spot on…

I’ve been in touch with TE, I will point them here

op1clockprob

#8

I got it working with Ableton for the most part, both in and out in Ableton midi preferences (for OP1) should have track/remote/sync enabled - this is strange as it suggests a loop sync from Ableton to OP1 and back


No luck with Logic Pro X unfortunately, it doesn’t play nice…

#9

Gosh this is infuriating. I hadn’t realized how messed up the OP-1 was with MIDI! I mean you can’t even use the thing with the OP-Z! It just will NOT play in the same clock… The darn thing (when I press start) will confuse the OP-Z and both will be playing in a slightly different timing.

This is totally a major bummer.