Op1 wont go to controlling screen with ableton live 10

hey friends. i have a problem with my op1 fw241 since some time.
i am trying to connect it to my mac and use it as a controller for ableton live 10. i downloaded the script and installed everything correctly but i wont work. i chose op1 in the ableton settings and turned in out and sync on, but my op1 wont change the screen to a controlling screen. after choosing comp -> control it just stays there and does nothing. it sends midi and i can use it as a midi keyboard and it plays the instrument in ableton AND i can change the octaves but thats all. i cant do any other controlls and i dont know the problem. its straight plugged into the mac.
i know that it once worked (i tried it some months ago) but i dont know what is different now. i installes the firmware from 237 to 241 just before that. it might be because of that.
does anybody have any ideas?

ps sorry for my bad english. its not my mother tongue

Согласен с тобой, аналогичная проблема: fw 241 (2019/11/22)

HI, I am having the same issue on my MacBook. Oddly enough, It works perfectly fine when plugged into my desktop PC - the op-1 control screen comes right up - but I cannot figure out how to bring it up on the Mac. I will keep fiddling with it and let you know if I can get it to work.

1 Like

OK I figured this out and have it working on my MacBook now. I was using the older scripts. The updated version (Latest commit 4f9193b on July 28, 2017) worked for me:

3 Likes

gonna try this today. thank you<3

1 Like

Hi mate, where did you find this version - it doesn’t seem to exist? Latest commit afaik is ab846d5 8 Jan 18.

TIA

Hi - strange, the link above in my May 5 reply is still working for me - goes to the July 28 commit. I see a jan 7 commit but it’s via a different link. The July 28 one is here:

https://github.com/pcppcp/op1

from the readme:

LAST UPDATE - 28 Jul 2017

  • code cleanup
  • docs

Mate are you using Live 9 or 10 because this link appears to take me to the Live 9 commit? I’m using Live 10?

Hi, I’m using Live 10 - I see that one is labeled under the live-9 branch, but it is the one that worked for me.

I tried that Live 9 version but it completely screwed my OP1 up. I thought I’d bricked it, but a factory restore seems to have fixed it. I’m leaving it, not risking it anymore. Glad it’s working for you.

Aw man, I’m sorry it didn’t work for you and for the touble it put you through. In my case it worked for PC and Mac Ableton, after no luck with any of the other versions.

(Incidentally I’m running with the 241 firmware, tho I just read there’s a 242 now)

The latest Live 10 version sort of worked for me. In ctrl (T2) mode I didn’t get the expected Ableton integration screen - midi worked but synth performance didn’t. If I switched to OP1 (T1) mode synth performance worked, but I got the occasional rouge note when I played the keys on my OP1.

I was using firmware 241. I’ve since upgraded so might try again. I’m also only using Ableton Basic.

I have installed the lastest ableton script available and still cannot get feedback or any control of ableton live beyond as a standard midi controller. has anyone had luck using the op-1 script in ableton 10? I am running the v.242 on my op-1. Any help?

I tried as well on Ableton Live 11 with firmware #243 but I do not get any visual feedback either, whereas I did on #242. I tried downgrading the firmware but ran into error message at boot.
Does anyone has any hint on this?

I am resurrecting this old thread because I, too, was trying to use my OP-1 as midi controller for Live 11.

I copied the script from the GitHub - marctdt/op-1-ableton-live-control-surface: Ableton Live Control Surface for Teenage Engineering OP-1 repository on the right folder in my Ableton installation but the OP-1 doesn’t switch to the controller screen.

I’m pretty sure it’s the script’s fault, as going through the source code, I can see that the script is supposed to log some messages to Ableton’s log file, but I don’t see those log messages in the log file.

Also, the script is supposed to send the “enable” sysex string to the OP-1:

0xf0, 0x00, 0x20, 0x76, 0x00, 0x01, 0x02, 0xf7

But i don’t see that string being sent to the OP-1 when monitoring the MIDI traffic with MIDI monitor.

In fact, when I manually send the string via SysEx Librarian, OP-1 correctly switches to Ableton controller mode.

I’m planning to do some more debugging and see what’s going on with this script.

Unfortunately, Imaginando (the original coders of the script) no longer maintain it, and TE basically said that they don’t do it either.

After some more debugging I changed my mind, the script should work fine, but the OP-1 is not cooperating: the script sends an identity request to the OP-1 upon startup:

xF0 x7E x7F x06 x01 xF7

OP-1 should answer with a identity sysex string, which should be captured by the handle_sysex function in the script. The script would then make sure that the device is actually an OP-1, by comparing some bytes with some expected values, and then send the sysex enable sequence, which switches the OP-1 to controller mode.

That never happens, and the script keeps trying to connect to the OP-1. This can be seen from the Log.txt file (mine is in ~/Library/Preferences/Ableton/Live 11.2.11):

2023-04-14T15:13:51.870746: info: RemoteScriptMessage: [TE OP-1] TRYING OP-1 CONNECTION
2023-04-14T15:13:52.893970: info: RemoteScriptMessage: [TE OP-1] TRYING OP-1 CONNECTION
2023-04-14T15:13:53.894922: info: RemoteScriptMessage: [TE OP-1] REFRESH STATE
2023-04-14T15:13:53.895814: info: Performance: Startup hook 'WriteUsageData': Running time: 0 ms
2023-04-14T15:13:53.902386: info: RemoteScriptMessage: [TE OP-1] TRYING OP-1 CONNECTION
2023-04-14T15:13:54.909148: info: RemoteScriptMessage: [TE OP-1] TRYING OP-1 CONNECTION

Firmware 243 introduced some changes in the sysex identity string (“updated: OP-1 sysex identity reply now reflects product family, model and firmware with actual version numbers. previously these values were zero”) but I guess these changes somehow broke the MIDI compatibility, at least for sysex handshaking.

I contacted TE asking them to check, hopefully we’ll get an update.

I’ll keep you posted.

1 Like

Any luck?

No unfortunately. I am in contact with TE. They also confirmed that the OP-1 (with firmware version 246) does not reply to the sysex identity request. It is not the expected behaviour so it remains to be seen whether they are going to correct it in a firmware update.