OPZ pitch bend

Hi,
my OPZ pitch bend is broken.
I’ve opened the OPZ and there must be a contact between two small contact surface (pitch bend down and pitch bend up) but the rubber button doesn’t do anything since the contact must be with a metal object.
That there is a small black part which must contain plastic and metal for each part of the contact plate

Is there a way to have this small black part ?

Thank you

No idea if this helps, but iFixit has a repair how-to for the button (you can order it online)

thanks but it didn’t worked. TE told that they don’t sell the part I’m looking for

1 Like

Ifixit is the seller , did you try them?

So you are actually missing the small black foil in between the rubber button and the contact (that it’s usually “glued” to)? How’s that?

I also tried to fix the sensitivity of my pitch bend but I don’t really understand, which part is defective. If I close the contacts underneath the rubber button and foil manually, it works just fine, going all the way up/down. But the foil that should do the job doesn’t seem to be conductive any more. Can anybody explain why it loses conductivity over time and what to do about it? Or is the “glue” some kind of conductive material, losing its functionality over time and the foil doesn’t do anything at all?

By the way D5 doesn’t help with this problem (like it does with the keyboard).

I would guess that it is a piezo electric sensor that detects pressure - either the sensor has failed or the soldered connection potentially could be reflowed

If you can take some close of pictures of what the foil and surrounding circuitry looks like, I might be able to make a better guess…

I’ll send a picture. Thank you

I found a video that explains how to replace it.

2 Likes