Phantom Copy upon extending step length

I realize that OP-Z doesn’t copy upon extending step length(like elektron boxes do), at least I think it doesn’t???
BUT first kick pattern I made this morning started at 16 steps(1bar), and when I changed to 64(4 bars)
It copied bar 1 to all bars! What the blarg?
I couldn’t get this to happen again. Has anyone experienced this?
It really should be an option, if it’s not already.

Maybe it should be an option. I’ve found a few instances (hi hat patterns, etc…) where it’s been pretty fun changing the sequencer resolution of a certain track in real-time. It’s pretty cool to be able to halve or double the speed of one track at a time while other stuff moves at the same speed around it as long as it is not interfering harmonically (wouldn’t make sense on a chord track if it will now be out of tune with ie the bass track).

That is the silver lining for sure, thanks for pointing that out, it is fun in some cases. Hopefully the copy upon extend will get added. Maybe just like that, copy pattern before extending. If no copy then just changes resolution.
Anyhow other than that so far I’m over the moon with this super fresh piece of kit!

That really would be a nice option. I’ve not seen it do that.