PO-20 No sound from internal speakers

Hi everyone,

Was having great fun with this little beast for a few days using the built in speakers. Last week, I plugged the top right output into some speakers in my friend’s studio. Everything was working fine.

But today, the first time I’ve used it since, the internal speakers are not working. No sound whatsoever unless I plug in speakers, then it works fine.

Any help would be greatly appreciated! Is my unit malfunctioning, or is there some noob setting that I’ve overlooked?

All the best,
DRMF

Have you tried holding the bpm/m button and pressing button 16?


CB
1 Like

I’ve had the same problem with the sub. A few weeks later it worked normal again. I belive it wasn’t the speaker that malfunctioned but the output jack

Hi folks, thanks for your help.

I tried the bpm combination already, it doesn’t seem to affect the volume.

It’s disappointing but reassuring to hear it could be a hardware fault with the jack!

I had the same problem with a PO-16.
on the back in the middle there is a loudspeaker symbol and a ’ + ’ above and a ’ - ’ below. I short-circuited these two points and then it worked again.
don’t ask me why, or why I did this. I am even very unsure if it was helpful at all.
I hope someone will reply if it works or not.